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Disclaimer
Please note that some modules and functions described in this manual might not be available in your client instance. This is the 
case if certain modules or functions are not required, applicable or requested and have been excluded on client’s explicit 
instruction.

All rights reserved. No parts of this manual may be reproduced in any form without the express written permission of bio.logis 
Genetic Information Management GmbH.

The information in this document is subject to change without notice.

bio.logis Genetic Information Management GmbH makes no representations or warranties with respect to the contents hereof. 
Every precaution has been taken in the preparation of this manual. Nevertheless, bio.logis Genetic Information Management 
GmbH assumes no responsibility for errors or omissions or any damages resulting from the use of the information contained in 
this manual.
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Diagnostic Report Module
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About DRM
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Summary DRM
This manual describes the Diagnostic Report Module which is a part of the Genetic Information Management Suite provided by 
bio.logis Genetic Information Management GmbH. The Diagnostic Report Module (DRM) has been developed as a tool for 
diagnostic laboratories. It supports the process of producing diagnostic reports resulting from genetic analyses by providing a 
platform for managing medical content and by automating certain work steps.

The DRM contains a fully functional Content Management System (GIMS-CMS) which is used for the creation and management 
of diagnostic report content. It also allows the definition of rules to determine which content applies under which circumstances.

The DRM also contains a Genetic Report Engine (GIMS-GRE). When clinical data resulting from a diagnostic test is imported 
into the DRM, the GIMS-GRE applies the appropriate rules to allocate the appropriate content from the GIMS-CMS into a 
diagnostic report.

The manual at hand will familiarize you with the use of the GIMS-CMS and how to set up and manage report content, users and 
workflows in order to allow an efficient report production.
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Version DRM
GIMS 1.12
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System requirements DRM
Firefox 45 on Windows 7 or 10
JavaScript enabled
No Ad blocking
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Contact DRM
Please contact us if there are any questions or support is required.

bio.logis Genetic Information Management GmbH
Olof-Palme-Straße 15
60439 Frankfurt am Main
Germany

E-Mail:  (for registered bio.logis DRM-Users only)support@biologis.com

mailto:support@biologis.com
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User Manual DRM
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General
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1.  
2.  
3.  

Logging in/out

Log in
Enter the username
Enter the password
Click Log in

 

Log out
In the , click (1)toolbar Log out .
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Using the toolbar
Depending on the selected menu item the shows toolbar 
different options.

If the 's name is selected, the toolbar shows user user
related menu options (1):

View profile
Edit profile
Log out

If  is selected, the toolbar shows content related menu Data
options (2):

Content
Media elements
Text elements
Templates
Report orders

If  is selected, the toolbar shows administrative Manage
menu options (3)

Configuration
People
Workflows

The  can be hidden by clicking the currently selected toolbar
menu item (4).

The  can be moved between vertically and toolbar
horizontally by clicking its toggle button (5).

https://confluence.biologis.com/display/HBGIMS/Templates+overview
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Using the test drive environment

To change from the productive environment to the test drive 
environment

Replace 'prod' with 'testdrive' in the URL (1)
Use the same login data as for the productive environment (2)

Please note: the test drive environment is a clone of the 
productive DRM environment which allows testing the user 
interface and new features. It reflects the content of the 
productive DRM environment. For a facilitated distinction 
the background of the test drive environment is colored gray 
and  is displayed with the DRM logo (3). Changes Test Drive
made in the test drive environment are not imported to the 
productive DRM environment. The test drive environment 
can be reset to the current status of the productive 
environment by the administrator.

 

How to get here

Default way:

Change from the  environment to the productive
 environment by replacing 'prod' with test drive

'testdrive' in the URL

Role
all

Possible next steps

Adding new content
Editing content
Translating contents
Integrating content
Generating a parameter tree
Adding content elements
Removing content elements from content
Editing a content element
Generating a parameter tree
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Users

 Users log into the DRM via their personal account. The user 
 account can be assigned different roles. These roles enable 

the user to perform various actions in the DRM.

Initially, users can be created by the administrator in the 
 DRM. Later, users with the role 'User Administrator' are able 

to create new user accounts, too.

Per default, bio.logis Genetic Information Management 
GmbH has 2 user accounts in each customer instance for 
handling support requests: gim-admin and gim-support.  If 
this is undesirable, the customer can deactivate it.

How to get here

Default way:

Toolbar > username 

Other ways:

Toolbar > Manage > People (needs Role User 
Administrator)

 > Toolbar Data > Content > Author: own username
Toolbar > Data > Text elements > First Author or Author > 
own username

Role
all

Possible next steps

Editing user profile

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar


Manual GIMS 1.12

20

Viewing user profile

Information about the user profile is shown (1):

Username
Time since account creation

 

How to get here

Default way:

Toolbar > username > View profile

Other ways:

Toolbar > Manage > People > own username (needs Role 
User Administrator)
Toolbar > username Edit profile > View > 
Toolbar > Data > Content > Author: own username
Toolbar > Data > Text elements > First Author or Author > 
own username

Role
all

Possible next steps

Editing user profile
Editing password

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
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1.  
2.  
3.  

4.  
5.  

Editing password

Enter the current password into  (1)Current password
Enter the new password into Password
The password strength shows the quality of the new password 
(2)
Repeat the new password into  (3)Confirm password
Click Save

 

 

How to get here

Default way:

Toolbar > username  Edit>

Other ways:

Toolbar > Manage > People > Operations: Edit (needs 
Role User Administrator)
Toolbar > username  View profile > Edit >

Role
all

Possible next steps

Editing user profile
Viewing user profile

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
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Editing user profile

 

 

Modify the following settings

E-mail address
Password
Status
Language settings
Local settings

Click .Save

Please note:
For the changes of roles, please contact the User Admin
istrator.

 

 

How to get here

Default way:

Toolbar > username Edit profile > 

Other ways:

Toolbar > Manage > People > Operations: Edit (needs 
Role User Administrator)
Toolbar > username View profile >  > Edit

Role
all

Possible next steps

Editing password
Viewing the own profile

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Viewing+the+own+profile
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Contents

Single contents in the form of text, images or barcodes can 
be managed in the DRM. I , tn addition hey can be merged 
into meaningful  for various questions e.g. report contents
templates. Different content types can be predefined  bio.by
logis, which can be configurated individually e.g. with a 
desired number and denomination of .  esections For ach 

 can be content type an unlimited number of contents
created.

Content types can be for example:

Clinical Report
Predefined content type for creating reports on test results

Genetic Counseling Report
Predefined content type for creating physician's letters 

Gene Card
Predefined content type for creating backup information on 
analyzed genes A portal title can be assigned.. 

Page fragment
Predefined content type for managing content of frequently 

 e.g. sidebar, header or footer in more than used sections
one clinical report (transmitted by )content integration

Content locking
Content locking is ing of a measure to avoid concurring edit
different users in the same content.

The content is locked for 30 minutes if a user opens a tab  of
the content where changes of the content can be  made
affecting the Edit, Parameter and Settings tab.  of the On top
content a notification to the locking status is set (1).

Another user who  the content is informed at the opens
same position by whom and for how long the content is 
already locked (2). After 30 minutes the content is released 
and automatically re-locked by the user who is editing it 

. firstly While the content is locked by another user, no one 
else can save changes but every tab with its content is 
visible.

In order to release the content for others , click on the earlier
 (3). A notification will confirm the unlock (4). link unlock

Logout also unlocks contents locked by this user.

How to get here

Default way:

Toolbar > Data > Content

Role
Content Editor
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Please note:

Modifications of content boxes and elements can be done while 
, but the changes  the content is locked by another user cannot

be saved.
Parameters can be sorted differently while the content is locked 
by another user. Only new classes or parameter  be set.cannot
Other translations are not affected by the content locking.
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Content overview

The list can be filtered by  title and language.content type,

The list shows the following information for each  (1)content

title
type
translation language
uuid
last author:  who edited the  userlast content
updated: time point of last saving
operations: possible actions, for example  or view edit

The list can be sorted by clicking on the corresponding title 
(available for title, type, language, author and updated).

 

How to get here

Default way:

Toolbar > Data > Content

Role
Content Viewer

Possible next steps

Adding new content
Viewing content
Editing the content
Viewing the parameters of the content
Viewing the workflow states of the content
Editing the settings of the content
Translating the content
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Adding new content

Click on   (1). Select the  (2).+ Add content content type

If only one content type is available, this one is used and the 
next page is shown directly. Content types can be created 
and deposited by the administrator.

Enter the title and select the .language

Click Save.

The content is  now.shown

 

How to get here

Default way:

Toolbar > Data > Content

Role
Content Editor

Possible next steps

Editing the content
Viewing the parameters of the content
Viewing the workflow states of the content
Editing the settings of the content
Translating the content
Viewing the history of the content
Publishing content
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Viewing content

On the  tab, the content is displayed in several View
sections. Amount and type of sections are customizable to 
optimally reflect the structure of content type (Adding a 

, section to content Removing sections from existing content
). 

Sections can for example be used to:

Structure the content of a  (1)clinical report
Structure the layout of a clinical report (2) (for further 
information see , )Page fragments Content integration
List all citations, that are linked to  (3)content boxes

Depending on whether a content is incomplete or 
contradictory, warnings can be displayed (1). Eliminate the 
cause of the warning,  a report can not be otherwise publised
under these conditions.

Selecting of general information, 
measurements and/or parameters
Select , general information and/or parameters
measurements in the block and click Report order values 

to see the content change accordingly (2).Apply 

Click  to empty the selection of parameters and all fields Clear
of general information and measurements filled with random or 
fixed  or manually entered values. Default values dummy values
are retained after clicking the  button.Clear

How to get here

Default way:

Toolbar > Data >   > title or Content View

Other ways:

Toolbar > Data > Content > Operations: Edit > View
Toolbar > Data >  >  Content Operations:  > Parameters
View
Toolbar > Data > > Content Operations:  > Workflow states
View
Toolbar > Data > Content > Operations: Settings > View
Toolbar > Data > > Operations:Content  Translate > View
Toolbar > Data >  Requested Report (the Report orders > 
given parameters will be selected)

Role
Content Viewer

https://confluence.biologis.com/display/HBGIMS/Working+with+page+fragments
https://confluence.biologis.com/display/GIMS/Content+integration
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
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Click  to go back to the last  of general information Reset setting
and measurements
Click  to fill in arbitrary values for parameters, Dummy values
general information and measurements
Optional: For general information and measurements with 
multiple input elements, values for each index can be entered. 
Click  to open the index field for entering the value 1 (3). Index 1
Click ' + ' to open a new index field (3b) and ' - ' to delete it (3c).
Optional: For parameter linked general information and 
measurements the associated parameter must be selected in 
addition to the value (4). Click into the  field, a Linked parameter
modal window opens for the parameter selection (4a). Click 

 and the desired parameters are displayed Apply in the Linked 
(4b). fieldparameter

Please note:

Computed general information and measurements are not 
displayed (see  (5)).Viewing computed content
Values of general information and measurements obtaining the 

.attribute   must be filledRequired
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Hovering over the content reveals the responsible  and rule
provides an  button to this specific  in the Edit content box
content form (6).

Per default,  are shown as tabs. In order to see all sections
sections at once, select  in the  show all Display sections
block in the right sidebar and click  (7).Apply
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The  block in the right sidebar shows the Translation
available translation languages and allows to switch 
between languages (8).

The index number of the  are shown below their references
 (9).content box

The last  of the  is automatically generated section content
and contains the  of all shown  in references content boxes
their order of usage, assigned by number (9a).

 
Possible next steps

Editing the content
Viewing the parameters of the content
Viewing the workflow states of the content
Editing the settings of the content
Translating the content
Editing the content (with the   preselected)content box
Viewing the history of the content
Publishing content

https://confluence.bio.logis.de/display/HBGIMS/Reference
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Viewing integrated content

View when using  content
integration:
The variables ( , , general information measurements

) of the contents are organized in tabs named parameters
after the corresponding content. Initially only the variables of 
the current content can be selected. After the selection, tabs 
of integrated contents occur consecutively. This has to be 
done step by step since each integration can be influenced 
by the selection of variables of previous content.

To fill the document with desired content boxes, enter values 
manually and click  or select  (5a)Apply Dummy values
A new tab occurs named after the first content from which one 

. or more sections have been integrated Select the new tab and 
either enter values manually and click  or select Apply Dummy 

. (5bvalues )
Optional: select variables for all following integrated contents to 
complete the content values. (5c)

Please note:

By clearing variables of one content, all following integrated 
content variables are cleared too and their tabs are not longer 
displayed.
By submitting values of one content by entering values 

, all manually and clicking  or selecting Apply Dummy values
following integrated content variables are cleared and just the 
tab of the current and the next content are shown. The other 
tabs are not longer displayed.
In case a is displayed, all desired values are report order 
transmitted. All tabs will be shown.
In case the same variables are assigned in more than one of 
the combined contents, values and preset attributes are taken 

s where they can not be changed.over in downstream content  
The entered values of these variables are saved even on the 

 tab of another content. Thus, values might be set already View
 and the belonging variables are locked in an integrated content

 until clicking the clear button.
A warning will occur if no variables were selected for a content. 
This warning does NOT prevent the report generation.

How to get here

Default way:

Toolbar > Data >   > title or Content View

Other ways:

Toolbar > Data > Content > Operations: Edit > View
Toolbar > Data >  >  Content Operations:  > Parameters
View
Toolbar > Data > > Content Operations:  > Workflow states
View
Toolbar > Data > Content > Operations: Settings > View
Toolbar > Data > > Operations:Content  Translate > View
Toolbar > Data >  Requested Report (the Report orders > 
given parameters will be selected)

Role
Content Viewer

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
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Viewing computed content

View when using processor 
:chains

If specific processor chains are used to output the content, 
can be generated in addition to the simple computed values 

values. All selected values are listed under the transformed 
values.

Click the  button (5d)Show transformed values
A modal window with all variables including computed and 
further processed general information, measurements  and/or 
parameters appears (5e)

Please note:

This list is for viewing only. No value can be changed here.
 and measurements are marked Computed general information

by a red star (5f).
 are displayed without values (5g).Protected general information

How to get here

Default way:

Toolbar > Data >   > title or Content View

Other ways:

Toolbar > Data > Content > Operations: Edit > View
Toolbar > Data >  >  Content Operations:  > Parameters
View
Toolbar > Data > > Content Operations:  > Workflow states
View
Toolbar > Data > Content > Operations: Settings > View
Toolbar > Data > > Operations:Content  Translate > View
Toolbar > Data >  Requested Report (the Report orders > 
given parameters will be selected)

Role
Content Viewer

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
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1.  

Editing content

The  is divided into , represented by gray content sections
boxes. Click on the tabs to switch between them (1). 
Changes to each section will be preserved even when 
switching between the sections.

Within a   display blue color. Content section, content boxes
 include  which display green color.boxes content elements

Content boxes and content elements can be

selected by clicking on them. Selected content boxes/elements 
are represented by darker colors.
added by clicking the  buttons: + Adding a content box to content
.
opened and closed by clicking the yellow buttons.

 

In the right sidebar the attributes and options of the , content
 and  are shown. They can content boxes content elements

be closed by clicking on the triangle in front of their title.

For the   following features are deposited in the content
 box (marked gray)(2):Content attributes

Title
Placeholders

For the  following features are deposited in content boxes
the  box (marked blue)(3):Content box attributes

Title
Exclusion set (initially disabled)
Rule
References
Exclusion set (initially disabled)
Active
Content integration
Move

For the  following features are deposited in content elements
three different boxes (marked green)(4):

Content elements attributes
Revisions
Title

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > Content > Operations:  > Parameters Edit
Toolbar > Data > > OperationsContent :  > Workflow states
Edit
Toolbar > Data > > OperationsContent : Settings > Edit
Toolbar > Data > > OperationsContent : Translate > Edit
Toolbar > Data >   > title or next to the Content View:  Edit
rule of a content box

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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1.  

Tags
Outdated
Move

2. Notes on

3. Similar content elements

The boxes in the right sidebar do only show the information 
for the currently selected content element or content box.

On the left buttons for further actions are deposited (5):

Blue * button: enabling the functionality for viewing and setting 
 exclusion sets

Yellow button: opening and closing all content boxes and 
content elements
Gray button with drag symbol: enabling the functionality for 

 and moving content boxes moving content elements

Gray button with floppy disk symbol: for saving the changes

 
Possible next steps

Adding a content box to content
Adding content elements
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1.  
2.  
3.  

Types of saving

Saving changes

Click the button on the left with floppy disk symbol
A box opens, where the  has to be selected (1).change class
Click Save

Please note:

Depending on the change class the content for the 
underlying parameter combination can fall back into another 

. workflow state By default major changes will cause the 
workflow state to be reset by normally several steps while 
minor changes will reset the workflow state by fewer or no 

 Therefore, minor changes are recommended for steps.
simple changes such as the correction of spelling mistakes. 
The selection of major changes is recommended for 
integration of new content or bigger reorganization.

As soon as  is edited, a confirmation is required to content
leave or reload the  tab without saving. In the modal Edit
window (2) click:

Stay on Page to keep the changes
Leave Page to discard all unsaved changes

Autosaving of not yet saved changes

Autosave is a feature which stores changes of the content 
that are not yet saved by the editor. This feature prevents 
loss of data in case of a breakdown of the system or power 
outage.

When returning to a content containing autosave states, a 
modal window opens. Click:

Resume editing to continue editing from the last autosaved 
state (3) or
Discard to discard all autosaved states (4)

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
 > Toolbar Data > Content > Operations:  > EditParameters

Toolbar > Data > Operations:Content >   > Workflow states
Edit
Toolbar > Data > > OperationsContent : Settings > Edit
Toolbar > Data > > OperationsContent : Translate > Edit

 > Data >   > title or next to the Toolbar Content View >   Edit
rule of a content box

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Please note:

only own changes will be considered for autosaving
the time of the last changes in the notice refers to the time 
zone preset for the user. For changing the time zone see 
Editing user profile

If the content is edited and saved by another user while you 
are editing it, you will be notified that autosave is being 
disabled and that all existing autosaved states are deleted. 
This is only a temporary measure and will be removed as 
soon as the feature "Concurrent Editing" is released (5).

 
Possible next steps

Adding a content box to content
Adding content elements
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1.  

2.  

3.  
4.  

5.  
6.  

7.  

Integrating content

Sections of basic contents can be included by adding them 
into a This process is called .content box. content integration

Select the content box where the basic content shall be 
embedded (1).
Use the autocomplete field within the  Content box attributes,
start to type the title of the  to be included and scontent elect the 
desired basic content from the list (2).
Select the desired  of the basic content (3).section
Optional: Click + to add a new item for integrating further 

 (4).content
Save.
On the content view, a combined parameter tree is displayed: 
the parameter tree of the basic content is included in the 
already existing parameter tree (5).
Hovering over the text shows the interlaced content boxes (6).

Please note:

The structure of combined contents is variable since individual 
sections of different contents can be integrated in the desired 
order.
Parameter / general information / measurement placeholders 
can be transferred from another content.
Included parameter  are s / general information / measurements
not shown in the rules and placeholder list.
If content should only be integrated under certain   parameter
conditions 2 strategies can be followed:

Generate a separate section in the basic content, 
including only the information about the parameter 
combination for which content is to be integrated.

 (no Enter this section into the combined content
second parameter tree is needed).

See  for the presentation of integrated content.Viewing content
Integrated content must be published before it is used in 
document generation. If content to be integrated is in another 
status than , the most recently published version is published
delivered.
Content can not be integrated circularly. For example content A 
is included in content B, content B cannot be included in 
content A at the same time.

How to get here

Default way:

Toolbar > Data >  > Operations:  Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > Content > Operations:  >Parameters  Edit
Toolbar > Data > Content > Operations:  > Workflow states
Edit
Toolbar > Data > > OperationsContent : Settings > Edit
Toolbar > Data > Content > Operations: Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Text+box
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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1.  

2.  

3.  

4.  

5.  

6.  

7.  
8.  

Example:

A combined clinical report  is generated by using  Nutrition
the single gene reports , Lactose intolerance Celiac disease 
and Haemochromatosis. While all results of the LCT and 
HLA DQ analysis should be reported, the results of the HFE 
investigation should only be mentioned if variant 1 was 
detected.

Add a new content with content type an the titleClinical report  
Combined report: nutrition.
Fill in the parameters and all content that is individual and 
cannot be integrated by other contents.
Create a content box at the position where the first section of 
the clinical report  shall be integrated (1), Lactose intolerance
select the content (2) and the desired section (3). Set the rule 
to  (4).Always true  
Optional: Click + to add a new item for integrating further 

.sections of the same content
Repeat step 2-4 for the linkage of the sections of the clinical 
report Celiac disease. 
Repeat step 2 for the linkage of the sections of the clinical 

. Define the rule report Haemochomatosis Results are in Variant 
 (5a) for the content box consisting the sections of 1

Haemochromotosis.Therefore, the existing parameter tree 
needs to offer this option. Otherwise include the desired 
parameter combination (5b).
Save.
On the content view, different parameter combinations show 
the corresponding content elements in the order and 

 prescribed on the Edit tab (6).depending on the given rules
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Possible next steps

Viewing content
Adding content elements
Editing a content element
Moving a content box
Setting an exclusion set to a content box
Setting references to a content box
Adding a content box to content
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Generating a report preview

On the view tab it is possible to generate a   of the Preview
 in the current state (1) . In order to do this a content

template needs to be  for this content. The preview selected
is created based on the selected .template

Select a file format (2) to create the preview with and click 
 (3).Apply

In case no  has been selected for this , the template content
 button (3) is set inactive and a message informs the Apply

user (4).

If module "DM Report Generator User Interface" is 
activated, the modal window appears with the message 
Please wait! Your report is being created.

If any  is defined, an additional form is flexible placeholder
displayed with the input request for the defined placeholders.

The user can fill the fields for the placeholders manually and 
click . Fields can be left empty, whereby the Apply
corresponding placeholder is deleted in the generated 
document.

Depending on the configuration of the browser

the preview can be saved in the  folderDownload
a new modal window opens with the possibility to either open 
(1) or save (2) the report preview. Click  (3) to confirm the OK
selection.

Usable only in combination with Report Layout Engine

How to get here

Default way:

Toolbar > Data >   > title or Content View

Role
Content Viewer

https://confluence.biologis.com/display/HBGIMS/Template
https://confluence.biologis.com/display/HBGIMS/Template
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
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Possible next steps

 Editing the content
Viewing the parameters of the content
Viewing the workflow states of the content
 Setting the used template
Translating the content
Viewing the history of the content
Publishing the content

https://confluence.biologis.com/display/HBGIMS/Editing+contents
https://confluence.bio.logis.de/display/HBGIMS/Viewing+the+parameters+of+a+content
https://confluence.bio.logis.de/display/HBGIMS/Viewing+the+workflow+states+of+a+content
https://confluence.bio.logis.de/display/HBGIMS/Translating+contents
https://confluence.bio.logis.de/display/HBGIMS/Viewing+the+history+of+contents
https://confluence.bio.logis.de/display/HBGIMS/Publishing+the+content
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1.  
2.  

Publishing content

Publishing contents
On the view tab the  block on the right displays the Workflow
used , the current , and the possible new workflow state

.states

This is only for the current language and  parameter
selection.

In case there are  with respect to the content or the warnings
current  does not allow transferring the content user's role 
into the next workflow state, the list of new states can be 
empty.

Corresponding to the workflow only the next defined state 
can be selected. Therefore, several publishing steps and 
possibly several users with different roles may be necessary 
in order to release a content for the publication.

Select the new state
Click  (1)Change state

The process can be repeated until the content has reached 
the state 'published'.

Please note:

The release processes can be modified for contents, single text 
elements and templates by the , see Workflow Editor editing a 

.workflow
In case content falls back into a non-published state, the most 
recently published version is delivered.
Templates must be published before they are used for 
document generation.
Integrated content must be published before it is used in 
document generation.

 

How to get here

Default way:

Toolbar > Data >   > title or Content View

Role
Content Viewer + 
Content Reviewer or 
Content Approver or
Content Publisher

Possible next steps

Editing the content
Viewing the parameters of the content
Viewing the workflow states of the content
Editing the settings of the content
Translating the content
Viewing the history of the content
Publishing content

https://confluence.bio.logis.de/display/HBGIMS/Workflow
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Editing+a+workflow
https://confluence.bio.logis.de/display/HBGIMS/Editing+a+workflow
https://confluence.bio.logis.de/display/HBGIMS/Role
https://confluence.biologis.com/pages/viewpage.action?pageId=34050888
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Viewing content workflow states

There are two places where the workflow state of the 
content is shown.

 

On content view tab
The  block in the right side bare displays the used Workflow

, the current , and the possible new  (1).workflow state states

This is only for the current translation language and 
 selection.parameter

In case there are  or the current  does warnings user's role 
not allow transferring the content into the next workflow 
state, the list of new states can be empty.

On content workflow 
states tab
Here the workflow states for all  combinations are parameter
shown for the current translation language.

The list contains

the parameters
the workflow state
the who has set the workflow stateuser 
the date when the workflow state has been set

 

How to get here

On content view tab:

Toolbar > Data >  > title or  Content View

On content workflow states tab:

Toolbar > Data >   > Operations: Content Workflow states
Toolbar > Data > Content > Operations: Edit > Workflow 
states
Toolbar > Data >  Content > Operations:  > Parameters
Workflow states
Toolbar > Data > > OperationsContent : Settings > 
Workflow states
Toolbar > : Data > > OperationsContent Translate > 
Workflow states

Role
Content Viewer

https://confluence.bio.logis.de/display/HBGIMS/User
https://confluence.bio.logis.de/display/HBGIMS/Role
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

Viewing the workflow states of the content
Editing the content
Viewing the parameters of the content
Editing the settings of the content
Translating the content
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Viewing content history

Temporary inactivated
A modal window opens with the overview of the  of revisions
the . Only the revisions which are different to the tentcon
previous revision are shown. For this, the current translation 
language and the current  selection are used.parameter

For each revision the following information is shown:

author: the  who created the revisionuser
changed: the date when the revision was created
revision id
compare from: needed for comparing two revisions
compare to: needed for comparing two revisions

To see the difference between two revisions, select them 
and click .Compare

To close the modal window, click x.

Removed content is marked in red and crossed out, new 
content is marked in green and underlined.

To go back, click  To close the Back to Revision Overview.
modal window, click x.

How to get here

Default way:

Toolbar > Data >   > title or Content View > 
Compare revisions

Role
Content Viewer

https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

Editing the content
Viewing the parameters of the content
 Viewing the workflow states of the content
Editing the settings of the content
 Translating the content
Viewing the history of the content
Publishing content
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1.  
2.  

Translating contents

The list displays in which languages the content is already 
available.

If you choose to add another translation an exact copy of 
the in the original language will be created. This content 
way the content structure,  tree,  parameter content boxes
and  as well as defined are already in content elements rules 
place and the user only has to translate the actual text 
within the content elements manually. If a used content 
element within the content already has a translation for the 
target language, this one will be used. All translated content 
elements will be marked as outdated to indicate that 
changes may be needed here. The outdated label is 
resolved, when the content is approved (see Publishing 

, )content Configuring workflows

Select the language for your new translation and click Add 
(1).

 

Optional: Enter a new title for the content
Click Save

On the view tab the  block on the right shows Translations
the available translation languages and allows to switch 
between them (4).

How to get here

Default way:

Toolbar > Data >   > Operations: Content Translate

Other ways:

Toolbar > Data > Content > Operations: View > Translate
Toolbar > Data > Content > Operations: Edit > Translate
Toolbar > Data > > Operations:Content   > Parameters
Translate
Toolbar > Data >  Operations:Content >   > Workflow states
Translate
Toolbar > Data > Content > Operations: Settings > 
Translate

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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For translating selected content elements, see Translating 
.content elements

 
Possible next steps

Editing the content
Viewing the parameters of the content
Viewing the workflow states of the content
 Editing the settings of the content
Translating the content
Viewing the history of the content
Publishing content

https://confluence.biologis.com/pages/viewpage.action?pageId=35750561
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Variables

User can define three different variables to denote patient-
specific data: parameter, general information or 
measurement. They are managed and transmitted to DRM 
by a requesting system (e.g. LIMS, LIS).

Variables can be used within rules or placeholders. As soon 
as the value of a variable is brought to DRM, a 
corresponding rule or placeholder can be fulfilled (note that 
the possible operations differ depending on the type of 
variable). This way, the user can customize the content 
accordingly with patient-specific data.

, parameters might represent Basically analysis results. 
General information can display patient-specific data in the 
form of verbal values and measurements can include 
numerical values.

Example variables:

A parameter can be the genotype of a proband (e.g. "wild 
type", "c.890A>G", "p.Lys297Arg", "F508del:hom").

A general information can be the name, gender, indication of a 
proband (e.g. "Patient Name", "Medical History", "Proband 
Date of Birth").

A measurement can be clinical testing results of a proband (e.
g. "Biomarker Testing Results", "Biochemical Testing Results", 
"Blood Count").

How to get here

Default way:

Toolbar > Data > Content > Title > Parameters

Toolbar > Data > Content > Title > Settings

Other ways:

Toolbar > Data >  > Operations: Content
Parameters

Toolbar > Data >  > Operations: Content Settings

Role
Content Settings Editor

Parameter Editor

Possible next steps

Adding and editing a class
Adding and editing parameters
Adding new general information
Adding new measurements
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Parameters
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Parameter overview

A parameter is patient-specific data which is delivered to the 
DRM. The delivered parameters determine the  content
output based on the set for the .rules content boxes

Example: Four different results of CFTR genotyping are 
visible as . Also a new parameter, not defined, is parameters
shown (1). They are divided into three  depending classes
on their zygosity (2). The parameter  are classes
subordinated the main class  (3).All parameters

As soon as the parameter structure is edited, a confirmation 
is required to leave or reload the  tab without Parameters
saving. In the modal window (4) click:

Stay on Page to keep the changes
Leave Page to discard all unsaved changes

On the  tab content linked to various parameter View
combinations can be made visible (5).

Please note:

How to get here

Default way:

Toolbar > Data >   > Operations: Content Parameters
 > ViewToolbar > Data > Content

Other ways:

Toolbar > Data > Content > Operations: View > 
Parameters
Toolbar > Data > > OperationsContent : > Edit Parameters
Toolbar > Data > > OperationsContent :  > Workflow states
Parameters
Toolbar > Data > Content > Operations: Settings > 
Parameters
Toolbar > Data > > OperationsContent : Translate > 
Parameters

Role
Parameter Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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In special cases parameters e.g. for cytogenetics are 
computed from other transmitted information. These 
computed parameters are not displayed in the  tab in View
the  block. They are made visible into a Report order values
modal without changing options (6). It is available by 
clicking the  - button (7).Show transformed values
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Possible next steps

Adding a class
Adding a dummy parameter
Adding a new metadata field
Editing a class, Editing a parameter, Editing metadata of a 
parameter
Inactivating a parameter
Reactivating a parameter
Viewing content
Editing the content
Viewing the workflow states of the content
Editing the settings of the content
Translating the content
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Adding and editing a class

How to edit:

to add classes: click on  (1)Add new parameter class
to edit classes: click the operation of an existing class (2)Edit 
Enter a name for the  (3).class
Set  visible that have to be shown on metadata fields

 of the class (4).parameters
Click  (5).Save

How to get here

Default way:

Toolbar > Data >  Operations Content > : 
 Parameters

Role
Parameter Editor

https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

Adding a class
Adding a dummy parameter
Adding a new metadata field
Editing a class, Editing a parameter, Editing metadata of a 
parameter
Inactivating a parameter
Reactivating a parameter
Viewing content
Editing the content
Viewing the workflow states of the content
Editing the settings of the content
Translating the content

https://confluence.biologis.com/pages/viewpage.action?pageId=35751769
https://confluence.biologis.com/pages/viewpage.action?pageId=35751769
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1.  
2.  

Adding and editing parameters

When , different kinds of generating a parameter tree
parameters can be assigned. There are two options:

Adding a  already existing in another contentreal parameter
Adding a  as a placeholder until thedummy parameter  

 real parameter is transmitted into the DRMappropriated

Adding real parameters from 
another content
How to add:

Click (1).Add an  parameter existing
Enter a name for the parameter (2) and select the right one 
from the list (3).
The modal window changes (4). Click .Save
Assign the  to a  by dragging it to the parameter class
appropriate position within the structure using the dragging 
symbol (5).

How to edit:

Click the operation of an existing real parameter (6). Edit 
Optional: change the selection by another real parameter from 
the list (7).
Click Save.

How to get here

Default way:

Toolbar > Data >  > Operations: Content
Parameters

Other ways:

Toolbar > Data >  > Requested  Report orders
Report Parameters > 

Role
Parameter Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Dummy parameters
How to add:

open the dropdown button and click Add new dummy 
(1)parameter 

Enter a name for the  (2) in the modal dummy parameter
window.
Click .Save
Assign the new  to a  by dragging it to the parameter class
appropriate position within the structure using the dragging 
symbol(3).

How to edit:

Click the operation of an existing dummy parameter (4). Edit 
Optional: change the name for the dummy parameter (5).
Optional: replace the dummy parameter by a real parameter (6).
Optional: in case the dummy parameter is in a  with visible class

, these fields can be filled.metadata fields
Click Save.
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Possible next steps

Adding a class
Adding a dummy parameter
Adding a new metadata field
Editing a class, Editing a parameter, Editing metadata of a 
parameter
Inactivating a parameter
Reactivating a parameter
Viewing content
Editing the content
Viewing the workflow states of the content
Editing the settings of the content
Translating the content

https://confluence.biologis.com/pages/viewpage.action?pageId=36866380
https://confluence.biologis.com/pages/viewpage.action?pageId=36866380
https://confluence.biologis.com/pages/viewpage.action?pageId=36866380
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Generating a parameter tree

The hierarchy of classes and parameters is generated by 
dragging and dropping all   into the preset   parameters class

.  and  are allocated by All parameters Classes  parameters
moving them below the parent class with an indent.

Note that each   must be at the end of a branch parameter
and that below a , there can be no other parameter

 or .parameter class

Click . Save

In case it is possible to replace a  by a dummy parameter
real , another  opens (see parameter page Replacing a 

).dummy parameter

New and new  appear on the first level    parameters classes
of the .parameter tree

The same  on the  tab:parameter tree content view

How to get here

Default way:

Toolbar > Data >   > Operations: Content
Parameters

Other ways:

Toolbar > Data > Content > Operations: View > 
Parameters
Toolbar > Data > > OperationsContent : > Edit Parameters
Toolbar > Data > > OperationsContent :  > Workflow states
Parameters
Toolbar > Data > Content > Operations: Settings > 
Parameters
Toolbar > Data > > OperationsContent : Translate > 
Parameters

Role
Parameter Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

Adding a class
Adding a dummy parameter
Adding a new metadata field
Editing a class, Editing a parameter, Editing metadata of a 
parameter
Inactivating a parameter
Reactivating a parameter
Viewing content
Editing the content
Viewing the workflow states of the content
Editing the settings of the content
Translating the content
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1.  

2.  

Replacing a dummy parameter

When , it may be possible to generating a parameter tree
replace  by . There are  dummy parameters real parameters
two options:

Replace the dummy parameter with a real parameter that 
already exists in the DRM in another content, but is not yet 
present in the current content.
Replace the dummy parameter with a real parameter 

 by another system e.g. transmitted LIMS

Replacement by a real parameter 
from another content

Click . A modal window opens.Edit
Enter the name of a real parameter and select the right one 
from the list (2).
Optional: Delete the dummy parameter name. Otherwise the 
parameter will be continued with this name in this content (3).
Click .Save
The replaced parameter is displayed in the parameter tree (4).

How to get here

Default way:

Toolbar > Data >   > Operations: Content
Parameters

Other ways:

Toolbar > Data > Content > Operations: View > 
Parameters
Toolbar > Data > > OperationsContent : > Edit Parameters
Toolbar > Data > > OperationsContent :  > Workflow states
Parameters
Toolbar > Data > Content > Operations: Settings > 
Parameters
Toolbar > Data > > OperationsContent : Translate > 
Parameters

Role
Parameter Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Replacement by real parameters 
from this content
When a new  is imported into the content, sort it parameter
into the same  as its corresponding  class dummy parameter
(1). Click Save.

For each new , that should replace a real  parameter dummy 
, select (2) otherwise . Select which parameter Yes ,  No

 in the same  should be replaced (3). dummy parameter class
Click  (4).Save

The  is replaced by all metadata of the dummy parameter
real parameter (6). The imported parameter is deactivated 

 and set to the end of the .parameter tree He also gets the 
addition EXCHANGED (5).

Optional: To adapt the name of the parameter, click  (6). Edit
Change the parameter name locally e.g. by using the global 
name (7). The new name ist displayed in the parameter tree 
(8).
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Possible next steps

Adding a class
Adding a dummy parameter
Adding a new metadata field
Editing a class, Editing a parameter, Editing metadata of a 
parameter
Inactivating a parameter
Reactivating a parameter
Viewing content
Editing the content
Viewing the workflow states of the content
Editing the settings of the content
Translating the content
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Inactivating a parameter

In order to make a parameter , confirm by clicking inactive
 in the modal window (1,2). Inactivate

The inactivated parameter is marked grey (3). Click Save.

On the View tab inactivated parameters are not visible in the 
selection of Report order values.

How to get here

Default way:

Toolbar > Data >  Operations Content > : 
Operations>  Parameters : Inactivate

Role
Parameter Editor

https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

Adding a class
Adding a dummy parameter
Adding a new metadata field
Editing a class, Editing a parameter, Editing metadata of a 
parameter
Inactivating a parameter
Reactivating a parameter
Viewing content
Editing the content
Viewing the workflow states of the content
Editing the settings of the content
Translating the content

https://confluence.biologis.com/pages/viewpage.action?pageId=36866381
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Reactivating a parameter

In order to reactivate a parameter, confirm by clicking 
 in the modal window (1,2).Reactivate

 

The reactivated parameter is marked black (3). Click .Save

On the View tab reactivated parameters are visible in the 
selection of Report order values again.

How to get here

Default way:

Toolbar > Data >  Operations Content > : 
Operations>  Parameters : Reactivate

Role
Parameter Editor

https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

Adding a class
Adding a dummy parameter
Adding a new metadata field
Editing a class, Editing a parameter, Editing metadata of a 
parameter
Inactivating a parameter
Reactivating a parameter
Viewing content
Editing the content
Viewing the workflow states of the content
Editing the settings of the content
Translating the content

https://confluence.biologis.com/pages/viewpage.action?pageId=36865791
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Working with metadata
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1.  
2.  

Adding a new metadata field

Click (1)Add new metadata field 
Enter the properties of the metadata field

Label: Enter a name for the field (2)
Translatable (3):

Mark the metadata field as translatable if the value is 
intended to be different in different translations of the 

. In this case, values entered into one content
translation of the content are restricted to this 
translations. In other translations, the same metadata 
field has to be filled separately.

Mark a field as not translatable if identical field content 
is intended to be used in all translations of the content
. In this case, values entered into one language 
version of the content will be carried over into all other 
translations.
Allowed number of value: unlimited or limited to a 
given number (4)

3. Click  (5)Save

How to get here

Default way:

Toolbar > Data >  Operations: Content >  
Parameters

Role
Parameter Editor

Possible next steps

Adding a class
Adding a dummy parameter
Adding a new metadata field
Editing a class, Editing a parameter, Editing metadata of a 
parameter
Inactivating a parameter
Reactivating a parameter
Viewing content
Editing the content
Viewing the workflow states of the content
Editing the settings of the content
Translating the content

https://confluence.bio.logis.de/display/HBGIMS/Role
https://confluence.biologis.com/pages/viewpage.action?pageId=35750571
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1.  

2.  

Connect metadata fields to parameters

If the  does not exist yet, see metadata field Adding a new 
.metadata field

Click the  operation of the  which contains all the Edit class
 who need the metadata (1).parameters

In the modal window, select   for the desired visible metadata 
 (2).fields

Click Save.

Optional: Click  (3). The metadata field is now visible for Edit
all parameters of the class (4).

How to get here

Default way:

Toolbar > Data >   > Operations: Content
Parameters

Other ways:

Toolbar > Data > Content > Operations: View > 
Parameters
Toolbar > Data > > OperationsContent : > Edit Parameters
Toolbar > Data > > OperationsContent :  > Workflow states
Parameters
Toolbar > Data > Content > Operations: Settings > 
Parameters
Toolbar > Data > > OperationsContent : Translate > 
Parameters

Role
Parameter Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role


Manual GIMS 1.12

76

Possible next steps

Adding a class
Adding a dummy parameter
Adding a new metadata field
Editing a class, Editing a parameter, Editing metadata of a 
parameter
Inactivating a parameter
Reactivating a parameter
Viewing content
Editing the content
Viewing the workflow states of the content
Editing the settings of the content
Translating the content
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Editing metadata of a parameter

In the open modal window, add or change the value of the 
.metadata

If the  is a , the entered parameter dummy parameter
 is only in the .metadata local context

The following information can be changed:

name of the parameter (1)
replacement of the dummy parameter by an existing parameter 
(2)
values of the visible metadata fields (3)

If the   is a real , metadata can be parameter parameter
changed locally (4), only in this content, or globally (5), in all 
contents (using this parameter).

How to get here

Default way:

Toolbar > Data > Operations Content > : 
 > Parameters Operations: Edit

Other ways:

Toolbar > Data >  > Requested Report orders
report > Parameters

Role
Parameter Editor

Possible next steps

Adding a class
Adding a dummy parameter
Adding a new metadata field
Editing a class, Editing a parameter, Editing metadata of a 
parameter
Inactivating a parameter
Reactivating a parameter
Viewing content
Editing the content
Viewing the workflow states of the content
Editing the settings of the content
Translating the content

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Content
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Role
https://confluence.biologis.com/pages/viewpage.action?pageId=35751766
https://confluence.biologis.com/pages/viewpage.action?pageId=35751766
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General information

General information (GIs) are patient or case-related data 
that are managed in external systems e.g. LIMS. They can 
be used to create a patient-specific clinical report within an 
automatic process of report generation. A general 
information is imported encrypted or unencrypted with a 

 into the DRM, the decryption is carried out in a report order
downstream system. General information can be integrated 
directly into  or by  content elements templates placeholders
or they can be used in the rule engine to decide under 
which conditions a with included content content box 
elements is presented in the delivered content.

Setting general information de
 fault values (1)

1) mandatory: ID 
The ID is predefined by the administrator. It is the unique 
universal identifier for this general information, used in 
communication of the DRM and external systems e.g. LIMS.

2) optional: Status, Description, Domain, Name
Freely available fields for adding metadata to the general 
information. These additional information can be included 
from external systems and can be applied in placeholders. If 
no value is imported, the here assigned default values is 
inserted into placeholders.

Please note:

A General information is displayed in the DRM with its name. In 
case a default name is not assigned here, the ID is shown.
Value fields are limited in their number of characters:
ID: 128
Description: 255

How to get here

Default way:

Toolbar > Data >  > SettingsContent

Other ways:

Toolbar > Data > Content > Operations: View > Settings
Toolbar > Data > Content > Operations: Edit > Settings
Toolbar > Data > > OperationsContent :  > Parameters
Settings
Toolbar > Data > > OperationsContent :  > Workflow states
Settings
Toolbar > Data > > OperationsContent : Translate > 
Settings

Role
Content Settings Editor

https://confluence.biologis.com/display/HBGIMS/Template
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Domain: 255
Name: 255
Value: unlimited

Setting general information 
attributes (optional)(2)

1) no attributes

patient-related data without direct reference to the person such 
as age, sex, medical indications
not strictly necessary: content will be delivered even if optional 
general information are not provided by LIMS
values are integrated into the content within the DRM

2) Required

patient-related data without direct reference to the person such 
as age, sex, medical indications
mandatory: content will be delivered only if all required general 
information are provided by LIMS
values are integrated into the content within the DRM

3) Protected

patient-related data with direct reference to the person such as 
name, family diagnosis
values transmitted to the DRM in encrypted form and decrypted 
in downstream systems
values are integrated into the content within the DRM
rule engine: can only be used in the rule 'is true'
placeholders: content is not displayed on the  tab, but is View
filled in the report
can not linked to computed, Linked to parameter(s), Multiple 
input elements

4) Computed

predefined by biologis GIM
detailed information generated automatically from patient-
related data/case-specific results such as cell line specific sex 
for cytogenetic analysis
is not displayed in the  block on the View Report order values
tab, but is listed in a modal available via the Show transformed 

 buttonvalues
values are generated automatically within the DRM during the 
preprocessing
recommended as extension for cytogenetic report templates
can not be linked to Protected
can not be linked to Required
dummy values cannot be set

5) Linked to parameter(s)

patient-related data in dependency of specific parameters
values are integrated into the content within the DRM
recommended as extension for cytogenetic report templates
can not linked to Protected

6) Multiple input elements

patient-related data with values extended by detailed 
information assigned as indices such as different titles in an 
adress header
rule engine: values or indices can be used
placeholders: values or indices can be used
values are integrated into the content within the DRM
can not linked to Protected
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Setting general information 
dummy values (optional)(3)
Dummy values can be defined here as a presetting for the 
review of content on the View tab (4). Click  Dummy values
and they will be used for the rule engine and filled in 
placeholders in the preview. For all details of a general 
information the random dummy value is predefined except 
the name, for which the default is set. The preset of dummy 
values can be changed.

1) Default
Assigned  (1) will be entered. default values In case of the 

 the default setting leads to an empty dummy value.Value

2) Random
A completely arbitrary sequence of 5 words from Lorem 
Ipsum texts will be entered. 

3) Fixed
The selection of Fixed opens a new field in which a static 
dummy value can be entered that will be transmitted then in 
the preview (5).

Please note:
Manually overwritten dummy values on the View tab will 
remain intact, even if the  button is clicked Dummy values
again.
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1.  

2.  

Adding new general information

Click the + (1) at the bottom of the  or Required Protected 
 to open a  block.General Information New General Information

To assign the definition of the new general information see 
.Default setting of general information

 

How to get here

Default way:

Toolbar > Data >  > Operations >  Content Settings

Role
Content Settings Editor

Possible next steps

Viewing content
Default setting of general information
Editing general information
Removing general information
Viewing the workflow states of the content
Translating the content
Viewing the history of the content
Publishing content
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1.  
2.  
3.  

Editing general information

Click the general information details to open it (1).
Change the content (2).
Save.

How to get here

Default way:

Toolbar > Data >  > Operations:  Content Settings

Role
Content Settings Editor

Possible next steps

Viewing content
Default setting of general information
Editing general information
Removing general information
Viewing the workflow states of the content
Translating the content
Viewing the history of the content
Publishing content

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Content
https://confluence.biologis.com/pages/viewpage.action?pageId=36866037
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1.  

2.  

Removing general information

Tick the checkbox for  at the bottom of the Remove General 
 details (1).Information

Save.

Please note:

If the general information is used as part of a rule or a 
placeholder, it is not possible to remove it. In such a case, a 
notification will displace the checkbox for  (1). Remove

How to get here

Default way:

Toolbar > Data >  > Operations:  Content Settings

Role
Content Settings Editor

Possible next steps

Viewing content
Default setting of general information
Editing general information
Removing general information
Viewing the workflow states of the content
Translating the content
Viewing the history of the content
Publishing content

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Content
https://confluence.biologis.com/pages/viewpage.action?pageId=36866061
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Measurements

Measurements, that are managed in external systems e.g. 
LIMS, can be used for creating a patient-specific clinical 

 within an automatic process of report generation. report
Measurements are transmitted with a  into the report order
DRM. They can be integrated directly into  content elements
by  or they can be used in the rule engine to placeholders
decide under which conditions a with included content box 
content elements is presented in the delivered content.

Setting measurement default 
values (1)
1) mandatory: ID 
The ID is predefined by the administrator. It is the unique 
universal identifier for this measurement, used in 
communication of the DRM and external systems e.g. LIMS.

2) optional: Status, Description, Domain, Name, Value
Freely available fields for adding metadata to the 
measurement.  additional information can be included These
from external systems and can be applied in placeholders. If 
no value is imported, the here assigned default values is 
inserted into placeholders.

Please note:

Measurements are displayed in the DRM with its name. In case 
a default name is not assigned here, the ID is shown.
Value fields are limited in their number of characters:
ID: 128
Description: 255
Domain: 255
Name: 255
Value: unlimited
Alarm: 255

How to get here

Default way:

Toolbar > Data >  > SettingsContent

Other ways:

Toolbar > Data > Content > Operations: View > Settings
Toolbar > Data > Content > Operations: Edit > Settings
Toolbar > Data > > OperationsContent :  > Parameters
Settings
Toolbar > Data > > OperationsContent :  > Workflow states
Settings
Toolbar > Data > > OperationsContent : Translate > 
Settings

Role
Content Settings Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Setting measurement 
attributes (optional) (2)
1) no attributes

patient-related data without direct reference to the person such 
as age, sex, medical indications
not strictly necessary: content will be delivered even if optional 
measurements are not provided by LIMS
values are integrated into the content within the DRM

2) Required

mandatory: content will be  if all required delivered only
measurements are provided by LIMS

not filled required measurements create a warning 
and prevent publication

values are integrated into the content within the DRM

3) Computed

predefined by biologis GIM
detailed information generated automatically from patient-
related data/case-specific results such as the number of 
metaphases counted per cell line for cytogenetic analysis
the setting is created automatically
is not displayed in the  block on the  Report order values View
tab, but is listed in a modal available via the Show transformed 

 buttonvalues
values are generated automatically within the DRM during the 
preprocessing
recommended as extension for cytogenetic report templates
can not be linked to Required
dummy values cannot be set

4) Linked to parameter(s)

measurements in dependency of specific parameters
values are integrated into the content within the DRM
recommended as extension for cytogenetic report templates

5) Multiple input elements

measurement values extended by detailed information 
assigned as indices
rule engine: values or indices can be used
placeholders: values or indices can be used
values are integrated into the content within the DRM

Setting measurement dummy 
values (optional)(3)
Dummy values can be defined here as a presetting for the 
review of content on the View tab (4). Click  Dummy values
and they will be used for the rule engine and filled in 
placeholders in the preview. For all details of a 
measurement the random dummy value is predefined 
except the name, for which the default is set. The preset of 
dummy values can be changed.

1) Default
Assigned default values (see above) will be entered. In case 
of the  the default setting leads to an empty dummy Value
value.
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2) Random
A completely arbitrary  will be entered:sequence

Description, Domain, Name and Alarm: 5 words from Lorem 
 Ipsum texts

Values, Percentage and Date: sequence of numbers 
Unit: any existing unit

3) Fixed
The selection of  opens a new field in which a static Fixed
dummy value can be entered that will be transmitted then in 
the preview (5).

Please note:
Manually overwritten dummy values on the  tab will View
remain intact, even if the  button is clicked Dummy values
again.
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1.  

2.  

Adding new measurements

Click the + (1) at the bottom of the or  Required  Optional 
 to open a  block.Measurements New Measurement

To deposit the definition of the new measurement see Default 
.setting of measurements

 

How to get here

Default way:

Toolbar > Data >  > Operations:  Content Settings

Role
Content Settings Editor

Possible next steps

Viewing content
Default setting of measurements
Editing measurements
Removing measurements
Viewing the workflow states of the content
Translating the content
Viewing the history of the content
Publishing content

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Content
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1.  
2.  
3.  

Editing measurements

Click on the  block to open it (1). Measurements
Change the content (2).
Save.

How to get here

Default way:

Toolbar > Data >  > Operations:  Content Settings

Role
Content Settings Editor

Possible next steps

Viewing content
Default setting of measurements
Editing measurements
Removing measurements
Viewing the workflow states of the content
Translating the content
Viewing the history of the content
Publishing content

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Content
https://confluence.biologis.com/pages/viewpage.action?pageId=36866499
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1.  

2.  

Removing measurements

Tick the checkbox for  at the bottom of the Remove
 details (1).Measurements

Save.

Please note:

If the measurement is used as part of a rule or a 
placeholder, it is not possible to remove it. In such a case, a 
notification will displace the checkbox for  (1).Remove

How to get here

Default way:

Toolbar > Data >  > Operations:  Content Settings

Role
Content Settings Editor

Possible next steps

Viewing content
Default setting of measurements
Editing measurements
Removing measurements
Viewing the workflow states of the content
Translating the content
Viewing the history of the content
Publishing content

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Content
https://confluence.biologis.com/pages/viewpage.action?pageId=36866520
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Content boxes
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1.  
2.  
3.  

Adding a content box to content

Within the  the  are allocated to content, content boxes
different . In order to add a content box, first select sections
the section for which you want to add a content box.

Click the + (1) at the bottom of the section
An empty  opens up (2)content box
Optional: Enter a title for the content box under Content box 

 in the right sidebar (3)attributes

 

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > Operations:Content   > Parameters Edit
Toolbar > Data > > Operations:Content   > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > :Data > > OperationsContent  Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Content
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

Adding content elements
Moving a content box
Setting the rule of a content box
Setting an exclusion set to a content box
Setting references to a content box
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Removing a content box from content

In order to remove a content box, it has to be selected.

Click the  button in the Remove content box Content box 
 in the right sidebar (1).attributes

In the modal window click .Yes

The content box is removed from the content.

 

How to get here

Default way:

Toolbar > Data > > Operations:   Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > Operations:Content   > Parameters Edit
Toolbar > Data > > Operations:Content   > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > :Data > > OperationsContent  Translate > Edit

Role
Content Editor

Possible next steps

 to content boxAdding a content
Moving a content box

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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1.  
2.  
3.  

4.  

Moving a content box

Within a section
Dragging has to be enabled by clicking on the gray button 
on the left with the drag symbol (1).

Change the order of the  within a  by content boxes section
dragging them (2).

Moved content boxes are marked with an asterisk (3).

To another section
Select the  that should be moved.content box
Open the  box in the right sidebar.Content box attributes
Under , select the target Move Content box to another Section

 (4).section
Click Move.

Please note: Moving is possible as soon the content 
element has been saved.

 

How to get here

Default way:

Toolbar > Data >  > Operations  Content > Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > Operations:Content   >Parameters  Edit
Toolbar > Data > > Operations:Content   > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > :Data > > OperationsContent  Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

Adding content elements
Editing a content element
Setting the rule of a content box
Setting an exclusion set to a content box
Setting references to a content box
Adding a content box to content
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Inactivating a content box

Content boxes are preset as active and are therefore visible 
in the . If a content box should not be used in the content
content, it must be inacitvated by removal of the checkmark 
in the  box (1).Content box attributes

To reactivate the content box, set the checkmark again.

 

How to get here

Default way:

Toolbar > Data >   > Operations > Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > Content   > Operations: Parameters Edit
Toolbar > Data >  Content >   > Operations: Workflow states
Edit
Toolbar > Data > Content >   Settings > Operations: Edit
Toolbar > Data > > Content  Translate > Operations: Edit

Role
Content Editor

Possible next steps

Adding content elements
Adding a content box to content

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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1.  

2.  

3.  

4.  

1.  

2.  

3.  

Setting the rule of a content box

Rules for  are set in the right sidebar, within content boxes
the Content box attributes.

Click  in the gray field (1). The modal window for setting the  Edit
rule opens.

If the content box should be displayed in any case, select 
 (2). Always true

If the content box should be displayed only for certain 
combinations of , select  (3).parameters Parameters (selected)
If the content box should be displayed for certain general 

 or , click on the corresponding information measurements
selection (3).

Select the desired operation. For details see Setting the rule for 
,  or parameters Setting the rule for general information Setting 

.the rule for measurements
Please note: rules for parameters, general information and 
measurements can be combined for a content box.

Click  to close the modal window Apply using the changes of 
.the rule

Click  to reverse the changes made.Reset
Click  to close the modal window without using the Cancel
changes of the rule.

Further opportunities:

Click , if the   shall be connected with a Add rule statement
further   by  (5). Set the new   as statement And statement
described above.
Click , if the   shall be connected with a Add group statement
further   by  (6). Set the new   as statement Or statement
described above. 
Click to remove the corresponding statement (7).Delete 

How to get here

Default way:

Toolbar > Data >  > Operations:  Content Edit

Other ways:

 > Data > Toolbar  Content > Operations: View > Edit
 > Data > Toolbar  Content > Operations:   > Parameters Edit
 > Data > Toolbar  Content > Operations:   > Workflow states

Edit
 > Data > Toolbar  Content > Operations: Settings > Edit
 > Data > Toolbar  Content > Operations: Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Role
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Please note: if the content box should never be shown, it is 
also possible to set it inactive, see Inactivating a content box
.

 
Possible next steps

Adding content elements
Editing a content element
Moving a content box
Setting an exclusion set to a content box
Setting references to a content box
Adding a content box to content

https://confluence.bio.logis.de/display/HBGIMS/Adding+content+elements
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Setting the rule for parameters

select  (3)Parameters (selected)
select the required operation (4)
select all classes or parameters (5) from the , for  parameter tree
which the rule applies
optional: select to set the rule depending on an with metadata 
specific  (6) metadata

select the  (7) and the metadata field metadata field
content (8)

It is recommended that the rules only contain  and classes
no explicit . This saves time writing  for parameter content
new parameters, since they only need to be sorted into the 
appropriate class.

Example:

If the selected   is rule Parameters (selected) are in LCT_-
, the   will be 13910TC:het, LCT_-13910TC:hom content box

used when one of these specific  is given.parameters

In contrast, if the    is used rule Parameters (selected) are in
for a whole , the connected content box will be used if class
one or more  are given.parameters

Example 2:

If the selected   is rule Results match exactly 2 parameters 
of...

class A1 and class A2, the   will be used when content box
exactly 1  is selected within  A1 and A2.parameter class

How to get here

Default way:

Toolbar > Data >  > Operations:  Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > Content Operations:  > Parameters Edit
Toolbar > Data > > Content Operations:  > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > Data > >Content  Operations: Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Rule is not fulfilled  Rule is fulfilled                          

classes B1, B2 and B3, the   will be used when content box
exactly 2 s are selected within these .parameter classes
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  Rule is fulfilled                               Rule is fulfilled
Rule is not fulfilled                             

 
Possible next steps

Adding content elements
Editing a content element
Moving a content box
Setting an exclusion set to a content box
Setting references to a content box
Adding a content box to content
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Setting the rule for general information

select  (3).General information
select the name of the desired  (4).general information  
Optional: Set the index (4a).
select the required operation (5).
insert a custom value (6, free-text field)

Please note:

If no name is assigned in the settings, the ID number is 
displayed in the selection.
General information are sorted in the selection according to 
their attributes. 

A distinction is made between general information with 
single or multiple values. After selection of a multiple 
general information, a further field appears for 
selecting the index associated with the desired 

. information (4a)
Protected general information are displayed 
separately. For protected general information only the 
rules  and   are possible. ' 'is  present ' 'is not present
Selecting another function resets the general 
information field to the first general information on the 
drop-down menu.

General information  can not be 'Linked to parameter(s)'
considered yet.

Example:

If the selected   is rule General information: Sex equals 
the   will be used for cases where the female, content box
 was defined as female in the LIMS and transferred proband

to the DRM.

If the selected   is rule General information: Indication 
 the content  will be used if any contains carcinoma,  box

cancerous disease is explicitly deposited with the wording 
 as indication for this case in the LIMS and carcinoma

transferred to the DRM.

 

How to get here

Default way:

Toolbar > Data >   > Operations > Content Edit

Other ways:

Toolbar > Data > Content > Operations:  View > Edit
Toolbar > Data > > Operations:Content   > Parameters Edit
Toolbar > Data > > Operations:Content   > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > :Data > > OperationsContent  Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

Adding content elements
Editing a content element
Moving a content box
Setting an exclusion set to a content box
Setting references to a content box
Adding a content box to content
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Setting the rule for measurements

Select  (3).Measurements
Select the name of the desired  (4).measurement
Select the required operation (5).
Select the desired value (6). If the custom value is selected (7) 
enter the value manually (8).
Optional: select a percentage, which is used to offset the value 
(9).

Please note:

If no name is assigned in the settings, the ID is displayed in the 
selection.
Measurements are sorted in the selection according to their 
attributes. A distinction is made between measurements with 
single or multiple values. After selection of a multiple 
measurement, a further field appears for selecting the index 

.associated with the desired information (4a)
Measurements can not be considered Linked to parameter(s) 
yet.

Example:

If the selected   is rule Measurement: leukocytes > Custom 
the  will be used for cases where value 30000, content box

more than 30000 leukocytes are detected indicating a 
leukaemia.

If the selected   is rule
a) Measurement: cholesterol > Reference value Minimum, 
associated via an connection to 'And' 
b) ,Measurement: cholesterol < Reference value Maximum
the   can be used for cases where cholesterol content box
values are within the reference range.

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > OperationsContent :  > Parameters Edit
Toolbar > Data > > Operations:Content   > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > :Data > > OperationsContent  Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

Adding content elements
Editing a content element
Moving a content box
Setting an exclusion set to a content box
Setting references to a content box
Adding a content box to content
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1.  

2.  

3.  

4.  

5.  

Extended rules

Rule extensions offer the possibility to display further 
conditions. They are optional and can be requested at bio.
logis Genetic Information Management GmbH.

The following rule extensions are available:

AND/ OR linkages can be changed at any time by clicking the 
button  or (1). The  of the darker coloured button is AND OR rule
set.
Additional single rules or rule groups can be created from the 

. By clicking  a new rule is set in the same same level Add rule
level. By clicking    are set in the same Add group a new rule
level selectable as AND or OR linkage to the previous rule.

 can be resorted by dragging on the Single rules or rule groups
drag symbol and dropping at the desired position in the rule 
chain.
 Additional  can be defined for further variables dependencies

 by setting the checkmark on the  coupled to parameters Linked
tag. By adding a group to a rule for parameters, the option '

' can be selected to link the preceding to the following Linked
statements.
Further rule operations for general information can be selected 
to negate statements.

 

How to get here

Default way:

Toolbar > Data >  > Operations:  Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > Content Operations:  > Parameters Edit
Toolbar > Data > > Content Operations:  > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > Data > >Content  Operations: Translate > Edit

Role
Content Editor

Possible next steps

Adding content elements
Editing a content element
Moving a content box
Setting an exclusion set to a content box
Setting references to a content box
Adding a content box to content

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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1.  
2.  

Setting an exclusion set to a content box

The functionality for viewing and setting exclusion sets has 
to be enabled by clicking the * button (1) on the left.

The  is set to   in the right  exclusion set content boxes
sidebar, within the Content box attributes.

Open the  in the dropdown menu (1)Exclusion set
At the bottom of the dropdown list, there is always one symbol 
that has not been used yet and is always free for defining a 
new exclusion set. Select a symbol, it appears in the empty 
field of the content box (2).

Example: A typical exclusion set is a set of content boxes 
that describe different results of genotyping (3). If 
interpretations of the results are in a new set of content 
boxes, they are another exclusion set (4).

 

 

 

How to get here

Default way:

Toolbar > Data >   > Operations > Content Edit

Other ways:

Toolbar > Data > Content > Operations : View > Edit
Toolbar > Data > > Operations:Content   > Parameters Edit
Toolbar > Data > > Operations:Content   > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > :Data > > OperationsContent  Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

Setting the rule of a content box
Setting references to a content box
Moving a content box
Adding content elements
Editing a content element
Adding a content box to content
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1.  

2.  

3.  

Setting references to a content box

References are set to   in the right sidebar, content boxes
within the (1)Content box attributes .

Type into the autocomplete field the pubmed id or part of 
author name or title.
Select the desired reference from the list of possible references 
(2).
To add more reference, click on the  button (3) and repeat the +
process.

 

On the  tab only the assigned number of the references View
is visible following the content box (4). The references are 
automatically presented at the  section (5).References

How to get here

Default way:

Toolbar > Data >  > Operations: Content  Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > Operations:Content   > Parameters Edit
Toolbar > Data > > Operations:Content   > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > :Data > > OperationsContent  Translate > Edit

Role
Content Viewer + Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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To remove references clear the  fields (1) and  References
click .Save
The references are no longer linked to the content box. 
They are not visible in the  then.content view

 

 
Possible next steps

Viewing content
Viewing the parameters of the content
Viewing the workflow states of the content
Editing the settings of the content
Translating the content
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Content elements
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Viewing content elements

Inside the content
On the  tab ,  and  are Edit text media barcode elements
visualized by a green frame.

Please note:

Translation elements cannot . be used in the content form
They are  at the T .displayed ranslation elements overview

 

How to get here

Default way:

Toolbar > Data > > content elementContent Edit > 

Role
Content Viewer

Possible next steps

Adding content elements
Viewing content elements
Editing a content element
Translating content elements

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
https://confluence.biologis.com/pages/viewpage.action?pageId=40964191
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Text elements overview

The list shows every existent  in the DRM. The text element
following information is displayed (1)

title
language: if a text element exists in more than one language, 
each language is listed separately
outdated: status to indicate whether a text element needs to be 
updated
first author:  who created the text elementuser
author:  who made the last savinguser
updated: time point of last saving
text (full-text)
operations

The list can be filtered by the , the and theTitle Language  
The text can be searched either for  status. Outdated

keywords or phrases (2). The entries can also be filtered by 
 (3). The search results are highlighted.their tags

The list can be sorted by clicking on the corresponding title 
(available for title, outdated, first author, author and 
updated).

 

How to get here

Default way:

Toolbar > Data > Text elements 

Role
Content Viewer

Possible next steps

Adding content elements
Viewing content elements
Editing a content element
Translating content elements

https://confluence.bio.logis.de/display/HBGIMS/User
https://confluence.bio.logis.de/display/HBGIMS/User
https://confluence.bio.logis.de/display/HBGIMS/Role
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Media elements overview

The list shows every existent in the DRM.  media element
The following information is displayed (1)

title
language: if a media element exists in more than one 
language, each language is listed separately
outdated: status to indicate whether a media element needs to 
be updated
first author:  who created the media elementuser
author:  who made the last savinguser
updated: time point of last saving
text: caption of the media element
operations

The list can be filtered by the , the and theTitle Language  
The text can be searched either for  status. Outdated

keywords or phrases (2). The entries can also be filtered by 
 (3). The search results are highlighted.their tags

The list can be sorted by clicking on the corresponding title 
(available for title, outdated, first author, author and 
updated).

 

How to get here

Default way:

Toolbar > Data > Media elements 

Role
Content Viewer

Possible next steps

Adding content elements
Viewing content elements
Editing a content element
Translating content elements

https://confluence.bio.logis.de/display/HBGIMS/User
https://confluence.bio.logis.de/display/HBGIMS/User
https://confluence.bio.logis.de/display/HBGIMS/Role
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Translation elements overview

The list shows every existent   in the Translation element
DRM. The following information is displayed (1)

title
language: if a translation element exists in more than one 
language, each language is listed separately
outdated: status to indicate whether a translation element 
needs to be updated
first author:  who created the translation elementuser
Last author:  who made the last savinguser
updated: time point of last saving
text (full-text)
operations

The list can be filtered by the , the and Keywords Language 
the Additional filtering is possible by  status (2). Outdated  

 or  within  (3). The search Tags Last author More filters
results are highlighted.

The list can be sorted by clicking on the corresponding title 
(available for title, language, outdated, first author, author 
and updated).

 

How to get here

Default way:

Toolbar > Data > Translation element

Role
Content Viewer

Possible next steps

Viewing content elements
Editing a content element

https://confluence.bio.logis.de/display/HBGIMS/User
https://confluence.bio.logis.de/display/HBGIMS/User
https://confluence.bio.logis.de/display/HBGIMS/Role
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Viewing a text element

There are two options to view text elements

from the  listtext elements overview
on the edit tab within a specific content

From text elements 
overview
Select the  and click on . The content title text element View
(1) and the content is shown on the left side (2).

On the right side the publishing workflow is described with 
its current state and assignee. The current state for this text 
element can be changed here (3).

The availlable languages of this text element are displayed 
in the box  (4).Translation

Within content
On the  tab text elements are visualized by a green Edit
frame.

 

How to get here

From text elements overview

Toolbar > Data >  > titleText elements

Within content

Toolbar > Data > > text elementContent Edit > 

Role
Content Viewer

Possible next steps

Adding content elements
Viewing content elements
Editing a content element
Translating content elements

https://confluence.bio.logis.de/display/HBGIMS/Text+element
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Viewing a media element

There are two options to view media elements

from the  listmedia elements overview
on the edit tab within a specific content

From the media 
elements overview
Select the  and click on . The title (1), media element View
the content (2) and the caption (3) of the media element is 
shown on the left side.

On the right side the publishing workflow is described with 
its current state and assignee. The current state for this 
content element can be changed here (4).

The availlable languages of this media element are 
deposited in the box  on the right (5).Translation

Within content
On the  tab media elements are visualized by a green Edit
border. The image (6) and the caption (7) are displayed and 
can be editied here.

How to get here

From media elements overview

Toolbar > Data >  > titleMedia elements

Within content

Toolbar > Data > > media elementContent Edit > 

Role
Content Viewer

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

Adding content elements
Viewing content elements
Editing a content element
Translating content elements
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Viewing a translation element

There is one option to view translation elements

from the   listTranslation elements overview

From translation 
elements overview
Select the  and click on . The translation element View
content title (1) and the content is shown on the left side (2).

On the right side the publishing workflow is described with 
its current state and assignee. The current state for this 
translation element can be changed here (3).

The availlable languages of this translation element are 
displayed in the box  (4).Translation

Comparing different translations is possible in box Compare 
 (5).with translations

 

How to get here

From translation elements overview

Toolbar > Data >   > titleTranslation element

Role
Content Viewer

Possible next steps

Viewing content elements
Editing a content element

https://confluence.biologis.com/download/attachments/65865026/Bildschirmfoto%202018-09-17%20um%2008.00.44.png?version=2&modificationDate=1537165501000&api=v2
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Adding content elements

Within the  the  are located within content, content elements
 which combine several content boxes text, barcode or 

with additional information.media elements 

In order to add a content element, the corresponding 
 has to be opened.content box

 

Adding a new content 
element

select the type of content element: ,  text element barcode 
,  (1a)element media element

click the + at the bottom of the  (1b).content box
an empty content element appears (2)
optional: Enter a title for the content element under Content 

 (3) and/or mark it with  (4) in the right element attributes tags
sidebar.

 

Filling a text element
type the text into the text element
optional: use  to style the text text editor features
Please note: these formats do not represent the final layout. 
they merely mark parts of the text for the definition of a layout.
save

Filling a barcode element
type the text into the barcode element, which is to be encrypted 
to a QR code (1)
optional: include general  (iterative and flexible placeholders
placeholders are not supported)
optional: change the size in which the QR code is displayed in 

(2). The wthe context (in percent) idth of QR codes in the 
delivered PDF and ODT documents will be shown in 

 percentage of the section page. Decide on a position where the 

How to get here

Default way:

Toolbar > Data >  > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > OperationsContent :  > Parameters Edit
Toolbar > Data > > Operations:Content   > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > Data > > Operations:Content  Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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 should appear in the content and whether it should be QR code
.flowed around by the following content element

save

Filling a media element
click  (1). A modal window opens.Select media
select an existing image (2a) or upload a new image (2b). 
Assisted formats are .jpg and .png.
click  (3). The modal window closes. The desired Select image
image is displayed in the media element.
optional: enter a caption (4). Use  to style text editor features
the text. Placeholders (general, iterative and flexible) are not 
supported.
optional: change the size in which the image is displayed in the 

(5). The wcontext (in percent) idth of images in the delivered 
PDF and ODT documents will be shown in percentage of the 

 section page.
optional: decide on a position where the   should appear image
in the content(6).
optional: decide whether the media element should be flowed 

.around by the following content element (7)
optional: slect margins around the image (8).
save.

Please note:

Translation elements cannot be added manually. They are 
created automatically when queried by a report order.

 
Possible next steps

Editing a content element
Text editor features
Moving a content element
Adding notes to content elements
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Adding an existing content element

Similar content elements
Similar  are displayed automatically in the content elements
sidebar while a content element is edited (1). This serves as 
an assistence to remember already existing content 
elements in the DRM instance. It is recommended not to 
duplicate but to reuse the same elements. Similar elements 
can also be used as a template for further processing.

Please note:

independently of the type of the content element, all elements 
containing similar context are displayed in the Similar content 

 boxelements
media elements can be found by selecting the same image

 cannot be added or reused. They areTranslation elements  
created automatically. 

Reuse text elements
click on the gray button on the left with the bullet point list 
symbol (2)
an   window including all text elements opens (3)overlay
optional: use the filtering options to find the desired text 
element (4)
click on the desired text element in the overview and drag it 
into the  (5)content box
click  on the gray button on the left with the bullet point list again

 to close the   window (6)symbol overlay

How to get here

Default way:

Toolbar > Data > Text/Media elements        and
 > Data >  > Operations:    Toolbar Content Edit

Other ways:

Toolbar > Data >Text/Media elements > Operations: View 
> Edit
Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > OperationsContent :  > Parameters Edit
Toolbar > Data > > Operations:Content   > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > Data > > Operations:Content  Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Reuse media elements 
while editing within a content, open the media elements 

 in another tab of the web browser (2)overview
optional: open a new content box (3)
select to the media elements overview
optional: use the filtering options to find the desired text 
element (4)
click on the media element in the overview and drag it into the 

 on the Edit tab (5,6)content box
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Optional:  of Processing
reused content elements

if changes are necessary decide to (7)
decouple: the element is no longer linked to the 
existing element used in other contents.
update: changes are saved for all contents where this 
element is used.

Click on  to see in which content the content Show usage
element is also used to make the decision easier (8)
save

Please note:

Translation elements cannot be added manually. They are 
created automatically when queried by a report order or a KMM 
placeholder is replaced.
If the content element is already present in the content box, it 
cannot be added a second time. A modal window with the 
corresponding message opens.
A content element can not be dragged into the text editor of 
another text element.

      In these cases, an error message is displayed.
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Possible next steps

Text elements overview
Media elements overview
Removing content elements from content
Editing a content element
Moving a content element
Adding notes to content elements
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Editing a content element

Inside the content
select the content element
make changes in the content element (1)
save

Please note:

If the content element has translations into other languages, 
they can be marked as  (2).outdated
Translation elements cannot be edited inside the content. For 
editing directly in the translation element see Editing a 

.translation element

Changes can be processed in the element attributesContent 
box in the right sidebar (3).

Text element

Media element

Barcode element

Content elements imported from an outside source are 
marked as locked and protected against editing. 
Translations of these content elements that are not imported 
but maintained inside the GIMS CMS may still be editable.

 

How to get here

Default way:

Toolbar > Data > > content element Content Edit > 

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

Viewing content elements
Translating content elements
Moving a content box 
 Adding notes to content elements

https://confluence.bio.logis.de/display/HBGIMS/Adding+a+note+to+a+text+element
https://confluence.bio.logis.de/display/HBGIMS/Adding+a+note+to+a+text+element
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1.  
2.  
3.  
4.  

Editing a text element

There are two options to edit text elements

from the  listtext elements overview
on the edit tab within a specific content

From text elements 
overview
Select the  and click text element .Edit 

The following changes can be made (optional):

Modify the title
Set or remove tags
Modify the text
Change the  state to mark this text element. In caseoutdated  

the option the text element has translations, Mark other 
 appears.translations as outdated

After modifying the content or the display of the text element 
it has to be defined how the changes will be applied 
(obligatory):

      5. After finishing the modifications the  has change class
to be selected
      6. Decouple or update this text element in all other 
contents. Click  to see other contents where it is Show usage
          used

The box in the right sidebar facilitates Compare revisions 
comparing texts .(7)

Click .Save

Within content
Text modifications are possible on the  tab. For details Edit
see .Editing a content element

 

How to get here

From text elements overview 

Toolbar > Data >  > title Text elements > Edit

Within content

Toolbar > Data > > text element Content Edit > 

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Text+elements+overview
https://confluence.bio.logis.de/display/HBGIMS/Text+elements+overview
https://confluence.bio.logis.de/display/HBGIMS/Text+element
https://confluence.bio.logis.de/display/HBGIMS/Tag
https://confluence.bio.logis.de/display/HBGIMS/Outdated
https://confluence.bio.logis.de/display/HBGIMS/Change+class
https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

Viewing content elements
Editing a content element
Translating content element
Moving a content box 
 Adding notes to content elements

https://confluence.bio.logis.de/display/HBGIMS/Adding+a+note+to+a+text+element
https://confluence.bio.logis.de/display/HBGIMS/Adding+a+note+to+a+text+element
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1.  
2.  
3.  

4.  

5.  
6.  

7.  

Editing a media element

There are two options to edit media elements

from the  listmedia elements overview
on the edit tab within a specific content

From media elements 
overview
Select the media element and click on .Edit 

The following changes can be made (optional):

Modify the title
Set or remove tags
Remove the image of this . media element The possibility to 
insert a new picture is given.
Decouple or update this media element in all other contents. 
Click  to see other contents where it is usedShow usage
Modify the caption
Change the size, margins or alignment of the displayed image 
and decide if the text should wrap the image (not  for selectable
the center setting). Modifications are assigned in all existing 
translations.
Change the  state to mark this media element and/or outdated
its translations. In case the  the media element has translations, 
option  appears.Mark other translations as outdated

The box in the right sidebar facilitates Compare revisions 
comparing texts (9).

Click .Save

           

Within content
Text modifications are possible on  (5). For details see Edit

, Editing a content element Adding content elements

 

How to get here

From media elements overview

Toolbar > Data >  > title Media elements > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Media+elements+overview
https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

Viewing content elements
Editing a content element
Translating content elements
Adding content elements
Moving a content box 
Adding notes to content elements

https://confluence.bio.logis.de/display/HBGIMS/Adding+a+note+to+a+text+element
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1.  
2.  
3.  
4.  
5.  

Editing a translation element

There is one option to edit translation elements

from the   listTranslation elements overview

From translation 
elements overview
Select the   and click  translation elements .Edit 

The following changes can be made (optional):

Modify the title
Set or remove tags
View original text
Modify the text
Change the  state to mark this text element. In caseoutdated  

the option the text element has translations, Mark other 
 appearstranslations as outdated

The box in the right sidebar facilitates Compare revisions 
comparing texts (6).
The Compare with translations box in the right sidebar 
facilitates comparing content of different translations (7).

Click .Save

 

How to get here

From translation elements overview 

Toolbar > Data >  > title Translation elements > Edit

Role
Content Editor

Possible next steps

Viewing content elements
Editing a content element

https://confluence.bio.logis.de/display/HBGIMS/Tag
https://confluence.bio.logis.de/display/HBGIMS/Outdated
https://confluence.bio.logis.de/display/HBGIMS/Role
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Text editor features
The following features exist for editing text

Formats
Styles
Bold
Italic
Underlined
Subscript
Superscript
Lists (numbered, bulleted, indents)
Horizontal line
Tables
Remove format
Paste options
Undo
Redo

Hover over the symbols of the text editor to see their 
description.

Please note:

these formats do not represent the final layout. they merely 
mark parts of the text for the definition of a layout
different styles can be applied on the same text phrase
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Formats
Click on the panel to select the .Format format

 

The following   exists for editing textformat

Normal
Heading 1 to 6

Each  may contain one format only. A content element
content element may not contain normal text together with a 
headline or several different headline types.

For the order of headings the following rules needs to be 
taken into account:

1) The  starts with heading 1.content
2) Each  starts with heading 1 or heading 2.section
3) The order of heading formats must not skip a hierarchy 
level. For example, heading 3 may not be defined if heading 
2 is not used  on the same section. Otherwise previously
there will be a  about  on the warning incorrect headings

 (see  for more information).content view troubleshooting
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1.  

2.  

3.  

Styles
Mark the text and select styles , ,  in the bold italic underline
bar.

On the  panel further styles exist:Styles 

small text
any  that has been  by the administrator.custom style configured

Styles can be applied to a single word or to text phrases.

Mark the phrase in the text that should be subject to a custom 
style.
Click on the desired custom style in the dropdown menu of 
Styles.
Click .Save

The custom style will now be displayed in the  and  Edit View
.mode

Please note:
For changing the custom styles, the previous style must be 

first. For this purpose clickdeactivated  on the custom style 
 once more.in the drop down menu styles
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Lists
It is possible to choose between numbered and bulleted lists.

To start a list click on the list symbol and a number/bullet 
appears. Insert your text and press Enter - the list is 
continued automatically.

Both list types allow to increase and decrease indents.

To end the list press Enter two times.
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Tables
To insert a table click on the table symbol.

In the first step the following table properties can be defined

Number of rows
Number of columns
Headers
Caption

Click to create the table.OK 

 

 

With a right-click on the table an extended properties menu 
opens, containing actions per

Cell
Insert cell before or after
Delete cell(s)
Cell properties (width, height, word wrap, alignment, 
etc.)

Row
Insert row before or after
Delete row(s)

Column
Insert column before or after
Delete column(s)

in addition with the following options

Paste
Delete table
Table properties (mentioned above)

 

 

To insert text before or after a table, a paragraph needs to 
be inserted first.

To insert this paragraph, select the table and hover over 
either the top or the bottom of it.

A white arrow on red background will appear. Click on the 
arrow to insert the paragraph.

Please note:

Not filled table rows are not visible on View, in the preview 
and the delivered document.

 
Information

At present, it is not possible to merge cells within tables, 
even though such actions exist for cells within the 
extended menu. We apologize for the inconvenience 
and go on working on a solution.
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Remove format
Use the option to convert text with different Remove format 
formats to unformatted text with one click.
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Paste options
The following paste options exist

Paste as plain text

Paste from Word 

Right-click > Paste 
Key combination (e.g. Ctrl+V for Windows, Cmd+V for Mac)

To paste formatted text as unformatted text use the Paste 
 option. All other options should preserve the as plain text

format of the copied text, as far as the editor is able to 
represent the formatting.

If a window appears, paste the text per key combination and 
click on OK.
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1.  

2.  

Editing an existing content element

If the  is reused, make changes (see content element Editing 
) and select how the modifications have to a content element

be applied. There are two options:

Update this  element at all places where it is reusedcontent
Should be selected if the modification needs to be updated 
globally in all contents, for example if a spelling mistake was 
corrected or an expression was updated (4). The   change class
of the content element modification has to be set (5).
Decouple this single element by creating a new onecontent 
Should be selected if the modificated content element is used 
only at the current position, for example when the interpretation 
of a parameter is changed only for this . The content content
element will not be changed in any other content (6).

           

Concurrent editing
In case two users change the same  in two content element
different contents at the same time, saving modifications by 
the first user will be unproblematic. Saving changes by the 
second user will create conflicts if the modifications are not 
the same.

A modal window appears. The affected element in the 
affected content is shown (7). To comprehend where the 
element is located in the content, click on it and the Conflict 
path opens (7a).

a) click  (8) to see the modification of Resolve conflicts
both users

How to get here

Default way:

Toolbar > Data > Text/Media elements        and
 > Data >  > Operations:    Toolbar Content Edit

Other ways:

Toolbar > Data >Text/Media elements > Operations: View 
> Edit
Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > OperationsContent :  > Parameters Edit
Toolbar > Data > > Operations:Content   > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > Data > > Operations:Content  Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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click  to see, where the content Show conflict path
element is used (9)
click  Revert all to switch all color codes (10). All green 
marked areas will be colored red and .vice versa
click  to  Apply all  accept the displayed modifications
(11). Changes  green will be applied, changes marked
marked red will be removed. To switch the color for an 

. marked area, click on it
optional: in case more than one content element is 
included in conflicts click  to Go to the next conflict
change to the next text for actualization.
click  (12) to exit the conflict Finish conflict resolution
resolution. The final version is shown in the content 

 now.element
optional: edit another content
click Save (13)

b) click  (14) tStart over o reset all modifications of the 
second user. The content will be reloaded in the last 
saved state including the changes of the first user or 

.others that have caused the conflicts. Click Save (15)

 

Possible next steps

Text elements overview
Media elements overview
Removing content elements from content
Editing a content element
Moving a content element
Adding notes to content elements
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Using similar content elements

 

 

When amending a content or setting up a new content, 
existing content elements from other contents can be 
reused. This makes sense for example when elements in 
different contents have identical or similar wording. For the 
integration of existing content elements see Adding an 

.existing content element

Changes within reused content elements are automatically 
transfered into other contents where the element is used.

When text is added in a new , the content element Similar 
 box in the right sidebar opens content elements

automatically if other existing content elements contain 
similar text (1).

Within this box, the search results for elements with similar 
text are displayed. For  the full text is text elements
compared, for  similarities of the captions media elements
are considered. Barcode elements are not considered.

When the  box is closed, its search Similar content elements
results will not be updated until it is opened again. Once it 
has been closed manually, it will not open automatically 
again.

Per default the similarity threshold is set to 75%, but using 
the slider it can be reduced to 25% or increased to 100% (2).

A maximum of five content elements are shown at once. 
Click the  and  buttons to browse through all next previous
suggested elements (3).

 

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > OperationsContent :  > Parameters Edit
Toolbar > Data > > OperationsContent :  > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > Data > > OperationsContent : Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role


Manual GIMS 1.12

146

Possible next steps

Editing a content element
Viewing content elements
Moving a content element
Adding notes to content elements



Manual GIMS 1.12

147

1.  
2.  
3.  

Viewing notes of content elements

Select the content element.
Open the : box in the right sidebar (1).Notes on
All  are displayed in the lower field.notes

 

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > OperationsContent :  > Parameters Edit
Toolbar > Data > > OperationsContent :  > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > Data > > OperationsContent : Translate > Edit

Role
Content Editor

Possible next steps

Editing a content element
Adding notes to content elements

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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1.  
2.  
3.  
4.  

Adding notes to content elements

Select the content element
Open the  box in the right sidebarNotes on: ...
Write the  in the upper field (1)note
Click Save

The note is saved under Previous Notes. The author and 
 (2).the date are also documented here

 

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > OperationsContent :  > Parameters Edit
Toolbar > Data > > OperationsContent :  > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > Data > > OperationsContent : Translate > Edit

Role
Content Editor

Possible next steps

Viewing notes of content elements
Editing a text element
Moving a content element

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Working with tags

 can be used to assign  to specific Tags content elements
categories to facilitate searching for thematic content. All 
translations are affected by tagging.

Tagging of content elements
Open the  in the right sidebar on the Content element attributes
Edit tab
Enter a  name (1)tag

 before, a drop down menu If the tag has been used
opens for choosing the right tag

 created and linked to their IDs, shown in New tags are
brackets, and are available for all contents after saving

Optional: enter further tags separated by commas (1)
Save

Please note:

 cannot be tagged inside the content. Translation elements T
ranslation element can be tagged in the Translation elements 

 list overview

Tagging of translation 
elements

Select the   and click  translation elements .Edit 
Enter a  name (2)tag
Optional: enter further tags separated by commas 
Save

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit
Toolbar > Data > Text/Media elements 

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > Operations:Content   > Parameters Edit
Toolbar > Data > > Operations:Content   > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > :Data > > OperationsContent  Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Filtering by tags
Open the ,  text elements overview translation elements 

 or . Already assigned tags overview media elements overview
are shown in the right box, the number of content elements 
linked to this tag is displayed in brackets (2).
Click a tag for viewing all  of this categorycontent elements

Click more than one tag or other filtering options for a 
combined search

Click ( -) to undo filtering

Please note:
Changing filtering options resets the selection of tags.

 
Possible next steps

Adding a content box to content
Moving a content box
Editing a content element
Adding notes to content elements
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Removing content elements from content

open the content element
click the  button in the Remove content element  Content

 in the right sidebar (1)element attributes
click  in the modal window (2)Yes

Please note: 
The content element will not be displayed in the content 
anymore. It is however not removed from the content 
management system and can still be used in other contents 
(see ). Adding content elements This also allows the removal 
to be reversed by reinserting the content element.

 

How to get here

Default way:

Toolbar > Data >  > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > Operations:Content   > Parameters Edit
Toolbar > Data > > Operations:Content   > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > :Data > > OperationsContent  Translate > Edit

Role
Content Editor

Possible next steps

Editing a content element
Moving a content element
Adding notes to content elements

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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1.  
2.  

Moving a content element

Within a content box
Dragging has to be enabled by clicking on the gray button 
on the left with the drag symbol (1).

Change the order of the  within a content elements content 
by dragging them (2). Moved content elements remain box 

marked with an asterisk.

 

To another content box
Select the  that should be moved.content element
Open the  box in the right sidebar (1).element attributesContent 

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > Operations:Content   > Parameters Edit
Toolbar > Data > > Operations:Content   > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > :Data > > OperationsContent  Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Text+element
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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3.  

4.  

Under  select the Move  element to another boxContent content 
target  (2).content box
Click Move.

 there is  If no content box at the final destination available 
  yet, a new content box can be generated (Adding a content 

)     the box to content or the content box including content 
element can be moved ( ).Moving a content box

Please note: Moving is possible as soon the content 
element has been saved.

 

 
Possible next steps

Adding a content box to content
Moving a content box
Editing a content element
Adding notes to content elements
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1.  
2.  

1.  

2.  

Managing content element revisions

Select the  tab or click the  Revisions Compare Revisions
button in the right sidebar in the  tab to open a modal Edit
window with the overview of  of the revisions content element
. Only the revisions made in the current translation of the 
content element are shown.

For each revision the following information is shown:

author: the  who has created the revisionuser
changed: the date when the revision has been created
revision ID
compare from: needed for comparing two revisions
compare to: needed for comparing two revisions

To close the modal window, click x.

To see the difference between two revisions, select them 
and click .Compare

 

Only the content but not the title of the content element is 
compared. 

Removed content is marked in red and crossed out, new 
content is marked in green and underlined.

To revert all changes:

Click  .Revert all
The modal window will be closed and the reverted content is 
shown within the  editor. text

Additionally, it is possible to accept or discard marked 
changes individually:

Click on the marked content. Labelling will change from red 
and crossed out to green and underlined and the other way 
around.
Click to delete the red marked content and keep the Apply all 
green marked content or 
click to keep the red marked content and delete the Revert all 
green marked content.

To go back, click  To close the Back to Revision Overview.
modal window, click  or .x Cancel

Text elements

Media elements

How to get here

Outside the content

Toolbar > Data >  > title >   Text elements Edit > Compare 
revisions
Toolbar > Data >  > title > Revisions Text elements  > 
Compare

Inside the content

Toolbar > Data > > Revisions Content Edit >  > 
Compare

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Revision
https://confluence.bio.logis.de/display/HBGIMS/User
https://confluence.bio.logis.de/display/HBGIMS/Role
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For media elements, changes of the following 
characteristics are displayed:

image
caption
alignment
width
wrap the next element.

 All, except the image, can be reverted by clicking the 
 button.Revert all

For ,barcode elements  changes of the text encrypted to the 
.QR code are displayed

Barcode elements

 

 
Possible next steps

Outside the content

Viewing content elements
Translating content elements

Inside the content

Editing content
Moving a content element
Adding notes to content elements
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1.  
2.  
3.  
4.  

5.  

1.  
2.  
3.  
4.  
5.  

6.  

7.  

Translating content elements

Select the language for the new translation and click  (1).Add

When creating a translation for a text element, the following 
actions can be applied:

Enter the translated title for the  (2).text element
Set  for the text element (3).tags
Translate the text (4).
The text element is marked as outdated. The labelling can be 
cancelled, if no changes are necessary. Optionally mark other 
translations as  (5).outdated
Click Save.

For translating the whole content see .Translating contents

When creating a translation for a media element, the 
following actions can be applied:

Enter the translated title for the media  (2). element
Set  for the media element (3).tags
Remove the image (4). It is possible to insert a new image.
Translate the caption (5).
Determine size and alignment of the image and decide if the 
following text should wrap it (6).
The media element is marked as outdated. The labelling can 
be cancelled, if no changes are necessary. Optionally mark 
other translations as  (7).outdated
Click Save.

For translating the whole content see .Translating contents

How to get here

Default way:

Toolbar > Data >   > title > TranslateText elements

Toolbar > Data >  > title >  elementsMedia
Translate

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

Viewing a content element
Editing the content element
Moving a content element
Working with tags
Adding notes to content elements
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1.  
2.  

Publishing content element

The   block displays the used  , the current Workflow workflow
, and the possible new  .state states

This is only for the current translation language.

Corresponding to the workflow only the next defined state 
can be selected. Therefore, several publishing steps and 
possibly several users with different roles may be necessary 

 In case in order to release a content element for publication.
the current    does not allow a transition, the list of user's role 
new states can be empty.

Select the new state
Click   (1)Change state

The process can be repeated until the content has reached 
the state .published

Please note:

The workflow can be modified by the , see Workflow Editor
.editing a workflow

In case content falls back into a non-published state, the most 
recently published version is delivered.

How to get here

Default way:

Toolbar > Data >  > title Text elements

Toolbar > Data >  > title  elementsMedia

Toolbar > Data >  > title Translation elements

Role

Content Viewer +
Content Element Reviewer or
Content Element Approver or
Content Element Publisher

Possible next steps

Editing a content element
Translating content elements

https://confluence.bio.logis.de/display/HBGIMS/Workflow
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/User
https://confluence.bio.logis.de/display/HBGIMS/Role
https://confluence.bio.logis.de/display/HBGIMS/Editing+a+workflow
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Placeholders

The same text can often be applied for different 
circumstances except for some details. For example, the 
interpretation can be true for different laboratory testing 
results. Texts needed for reporting such results differ from 
each other only where the exact result is reported. In such 
cases,   can be used within a  placeholders content element
or  to template create fields where context specific 
information can be integrated exactly for the desired 
situation.

 

Placeholders can be used for , parameters general 
,  and also for whole content information measurements

elements. Background information for parameters can be 
provided as . For general information and metadata
measurements all information assigned to them in the 
settings can be integrated as placeholders in the content 
element.

 represent a special case: they Rule-based placeholders
source their information from content elements and can be 

. filled rule depending by various contents

On the View tab, placeholders which are not filled because 
the associated parameter is not selected, show the node 
designation of the related content as well as the placeholder 
name manually assigned by the user, e.g.  [[node_2:gene]].
The node can be used to trace back from which content the 

 in case of .placeholder was transferred content integration

3 specific placeholders with different functions are available:

1) in generalPlaceholders 
2) Iterative placeholders
3) Flexible placeholders

 

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > OperationsContent :  > Parameters Edit
Toolbar > Data > > OperationsContent :  > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > Data > > OperationsContent : Translate > Edit

Role
Content Editor

Possible next steps

Viewing placeholders
Adding a placeholder
Editing a placeholder
Working with metadata
Removing a placeholder
Moving a content element 

https://confluence.biologis.com/display/HBGIMS/Template
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
https://confluence.bio.logis.de/display/HBGIMS/Adding+a+note+to+a+text+element
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Adding notes to content elements
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Viewing placeholders

Viewing general and 
iterative placeholders
Placeholders for ,  and parameter general information

 can be found in  of the measurements  content elements
. They are administered in the  in content Content attributes

the right sidebar (1). All of these placeholders can be 
converted to iterative placeholders.

Rule-based placeholders are tagged by an exclusion set in 
the right sidebar. All content boxes with the same exclusion 
set symbol can be integrated in the placeholder in case their 
rule applies.

Viewing flexible 
placeholders
Flexible placeholders can be found in the corresponding 

 or . Linkagecontent element template  to specific information 
of   or  must be general information measurements
established by the administrator or the placeholders can be 
filled manually during document generation.

 

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > OperationsContent :  > Parameters Edit
Toolbar > Data > > OperationsContent :  > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > Data > > OperationsContent : Translate > Edit

Role
Content Editor

Possible next steps

Adding a placeholder
Editing a placeholder
Removing a placeholder
Moving a content element
Adding notes to content elements

https://confluence.biologis.com/display/HBGIMS/Template
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Adding a placeholder

Adding a placeholder
To add a general placeholder, first decide whether the 
information to be inserted contains details about parameters 
(with metadata), general information or measurements.

For further details see , Adding a parameter placeholder
, Adding a general information placeholder Adding a 

.measurement placeholder

 

Adding an iterative 
placeholder
To generate a list of data in a table or as a bulleted or 
numbered list in a content element, , parameter general 

 and  can be information measurement placeholders
converted to .iterative placeholders  In case of incorrect 
handling look for the affected content element in the content 
elements overview and correct the content by adding a table 
or list to iterative placeholders.

First create a placeholder (  Adding a metadata placeholder,
, Adding a general information placeholder Adding a 

). Transfer it into a table (1) or use measurement placeholder
one of the list features, either bulleted (2) or numbered (3). 
Supplement the string by {{ in the beginning and }} at the 
end. In the view mode the list of metadata of all selected 
parameters is shown. For general information and 
measurements a list of the settings values of all selected 
general information/measurements is shown.

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > OperationsContent :  > Parameters Edit
Toolbar > Data > > OperationsContent :  > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > Data > > OperationsContent : Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
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Adding a flexible placeholder
To add a , write a string starting with [# flexible placeholder
and end  with #] within a  or . The content element template
string in between is the identifier for the placeholder 
replacement.

Please note: Templates are usable only in combination with 
the Report Layout Engine.

Example: Design of the Header of a clinical report.

flexible placeholders are deposited in the template (1)
after  and  Adding a new template Setting the used template
create a new report preview on the  tab of the content. View
The flexible placeholders are displayed in a modal window and 
can be filled with report specific data (2).
click  and the report preview with integrated data will be Apply
generated.

Adding a rule-based 
placeholder
There are three different ways to add a rule-based 

 to the :rplaceholde content

Writing a content element
Write a string within a  starting with [[ and content element
ending with ]] (1)
Click somewhere outside the content element
A modal window opens confirming the new placeholder (2)
Click  and the placeholder will be added to the list (3)OK
From the select list ( ) select Select placeholder type Rule-based 

 (4)placeholder
Select an exclusion set to flag the placeholder (5)
Create a content box including content that shall be integrated 
under certain conditions (6a)
Select the same exclusion set for the content box as for the 
rule-based placeholder (7a)

https://confluence.biologis.com/display/HBGIMS/Template
https://confluence.biologis.com/display/HBGIMS/Adding+a+new+template
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Select the rule for which the content  in the shall be added
 (8a)placeholder

Mark the content box as (9a)Includable 
Repeat 7 - 10 for all possible contents for the rule-based 
placeholders (7b - 9b)
Click Save

Reusing a content element
Adding content elements which contains rule-based 
placeholders
A modal window opens confirming the new placeholders (2)
Click  and the   placeholder will be added to OK new rule-based
the list (3)
Adjust the exclusion set of the rule-based placeholder (4,5)
Create a content box including content that shall be integrated 
with exclusion set, rule and  flag (7-9)Includable
Click Save

Define placeholders manually
Click  below the list of the used placeholders (1)+
From the select list ( ) select Select placeholder type  Rule-based

 (2)placeholder
Select an exclusion set (3)
Fill in a name between [[...]] (4)
Copy the name [[...]] into the content element (5)
Create all content boxes including content that shall be 
integrated with exclusion set, rule and   flag Includable  (6)
Save

On the  tab View the rule-based placeholder is replaced with 
the desired content if the rule of one underlying content box 

 (10).is fulfilled

Please note:

only the content of the first  with fullfilled rule will be content box
included regardless of other content boxes whose rules are 

. The  fulfilled as well exclusion sets define exclusive content 
.and prevents their common delivery

s must be prevented: do not integrate the content endless loop
box A into the content box B and vice versa.
includable content box contains less . Headings text formats
and tables can not be set.
content boxes marked as  will not be displayed in the Includable
location they are placed on the edit form (no matter if their rule 
matches or not) but only as replacement for a rule-based 
placeholder.
on View tab: if rules for several includable context boxes are 

 for the replacement, only the content of the first box is fulfilled
 instead of the placeholder, a  is shown.displayed warning

 is possible if the content box with the rule-content integration
based placeholder and all includable content boxes are  set on 
the section to be integrated

https://confluence.biologis.com/display/HBGIMS/Text+editor
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Possible next steps

Adding a placeholder
Editing a placeholder
Removing a placeholder
Moving a content element
Adding notes to content elements
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Adding a parameter placeholder

Before integrating parameter specific information into the 
content, the required metadata have to be assigned to the 
parameters (for details see ).Working with metadata

There are three different ways to add a metadata 
 to the :placeholder content

 

Writing a content element
Write a string within a starting with [[ and content element 
ending with ]]  (1)
Click somewhere outside the content element
A modal window opens confirming the new placeholder (2). 

 (3)Click  and the placeholder will be added to the listOK
From the select list ( ) select Select placeholder type Parameter 

 (4)placeholder
Adjust the parameter(s) (5)
Select metadata field. Choose between the name of the 

 (6a, parameter  (6) and the content of a metadata field Working 
)with metadata

Insert the name of the placeholder if not already done in the text
 (7)
Optional: configure delimiters for enumerations of included 
values (8)
Click Save

Reusing a content element
Adding content elements which contains parameter 
placeholders
A modal window opens confirming the new  r paramete
placeholders (2).
Click  and the parameter placeholder will be added to the OK
list (3).
From the select list ( ) select Select placeholder type r Paramete

 (4)placeholder
Adjust the parameter(s)  and metadata field (6)(5)
Click Save

 

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > OperationsContent :  > Parameters Edit
Toolbar > Data > > OperationsContent :  > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > Data > > OperationsContent : Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
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https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
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On the  tab View the placeholder is replaced with the 
deposited metadata as soon as a specific parameter has 

 (9).been selected

Define placeholders manually
Click  below the list of the used placeholders (1)+
From the select list ( ) select Select placeholder type Parameter 

 (2)placeholder
Select parameter(s) from the parameter tree (3)
Select the metadata field (4)
Fill in a name between [[...]] (5)
optional: configure delimiters for enumerations of included 
values (6)
Copy the name [[...]] into the content element(7)
Click Save
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Possible next steps

Adding a placeholder
Editing a placeholder
Removing a placeholder
Moving a content element
Adding notes to content elements
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Adding a general information placeholder

There are three different ways to add a general information 
 to the :placeholder content

 

Writing a content element
Write a string within a  starting with [[ and content element
ending with ]] (1).
Click somewhere outside the content element.
A modal window opens confirming the new placeholder (2).
Click  and the placeholder will be added to the list (3).OK
From the select list ( ) select Select placeholder type General 

 (4).information placeholder
Select the general information (5) and the setting (6). Optional: 

. More than in case of , select the indexMultiple input elements
one selected general information with multiple input is currently 
not supported.
Optional: configure delimiters for enumerations of included 
values (7).
Click Save.

Reusing a content element
Adding content elements which contains general information 
placeholders.
A modal window opens confirming the new general information 
placeholder (2).
Click  and the   placeholder will be OK new general information
added to the list (3).
Adjust the settings of the placeholder (4, 5, 6).
Optional: configure delimiters for enumerations of included 
values (7).
Click Save.

 

On the  tab View the placeholder is replaced with the 
deposited information as soon as a specific general 

 (8).information has been selected

Please note:

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > OperationsContent :  > Parameters Edit
Toolbar > Data > > OperationsContent :  > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > Data > > OperationsContent : Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
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The value field must always be filled, regardless of whether it is 
 rules or placeholders. Otherwise the general used for

information cannot be detected.
The value fields are limited in their number of characters (see 

). General information This affects both dummy and real 
transmitted values.

Define placeholders manually
Click  below the list of the used placeholders (1).+
From the select list ( ) select Select placeholder type General 

 (2). placeholderinformation
Select one or more general information (3).
Select the general information setting (4).
Fill in a name between [[...]] (5).
Optional: configure delimiters for enumerations of included 
values (6).
Copy the name [[...]] into the content element (7).
Click Save.

 
Possible next steps

Adding a placeholder
Editing a placeholder
Removing a placeholder
Moving a content element
Adding notes to content elements
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Adding a measurement placeholder

There are three different ways to add a measurement 
 to the :placeholder content

 

Writing a content element
Write a string within a  starting with [[ and content element
ending with ]] (1).
Click somewhere outside the content element.
A modal window opens confirming the new placeholder (2).
Click  and the placeholder will be added to the list (3).OK
From the select list ( ) select Select placeholder type

 (4). Measurement placeholder Optional: in case of Multiple 
. , select the indexinput elements More than one selected 

measurement with multiple input is currently not supported.
Select one or more measurement(s) and the setting(s) (5, 6).
Optional: configure delimiters for enumerations of included 

.values (7)
Click . Save

Reusing a content element
Adding content elements which contains measurement 
placeholders.
A modal window opens confirming the new measurement 
placeholders (2).
Click  and the   placeholders will be added OK new measurement
to the list (3).
Adjust the settings of the placeholders (4, 5, 6).
Optional: configure delimiters for enumerations of included 
values (7).
Click . Save

 

On the  tab View the placeholder is replaced with the 
deposited information as soon as specific measurements 

 (8).have been selected

Please note:

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > OperationsContent :  > Parameters Edit
Toolbar > Data > > OperationsContent :  > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > Data > > OperationsContent : Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
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The value field must always be filled, regardless of whether it is 
 rules or placeholders. Otherwise the general used for

information cannot be detected.
The value fields are limited in their number of characters (see 

). Measurements This affects both dummy and real transmitted 
values.

Define placeholders manually
Click  below the list of the used placeholders (1).+
From the select list ( ) select Select placeholder type

 (2). placeholderMeasurement
Select one or more measurements (3).
Select the measurement setting (4).
Fill in a name between [[...]] (5).
Optional: configure delimiters for enumerations of included 
values.
Copy the name [[...]] into the content element (6).
Click Save.

 
Possible next steps

Adding a placeholder
Editing a placeholder
Removing a placeholder
Moving a content element
Adding notes to content elements
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Adding a parameter linked general information 
placeholder

There are three different ways to add a parameter linked 
 to the :general information placeholder content

 

Writing a content element
Write a string within a  starting with [[ and content element
ending with ]] (1)
Click somewhere outside the content element. A modal window 
opens confirming the new placeholder (2)
Click  and the placeholder will be added to the list (3)OK
From the select list ( ) select Select placeholder type Parameter 

 (4)linked General information placeholder
Adjust the parameter(s) for that the placeholder should be filled 
(5)
Adjust the general information (6a), select the setting (6b). 
Optional: in case of , select the index Multiple input elements
(6c). More than one selected general information with multiple 
input is currently not supported.
Optional: configure delimiters for enumerations of included 
values.
Click . Save

Reusing a content element
Adding content elements which contains parameter linked 
general information placeholders
A modal window opens confirming the new placeholders (2)
Click  and the   OK new parameter linked general information
placeholders will be added to the list (3)
From the select list ( ) select Select placeholder type Parameter 

 (4)linked General information placeholder
Adjust the parameter(s) for that the placeholder should be filled 
(5)
Adjust the general information (6). Optional: in case of Multiple 

 , select the index (6a).input elements More than one selected 
general information with multiple input is currently not 
supported.
Select the setting (7). 
Optional: configure delimiters for enumerations of included 
values (8).
Click Save.

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > OperationsContent :  > Parameters Edit
Toolbar > Data > > OperationsContent :  > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > Data > > OperationsContent : Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
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On the  tab:View

       8. Fill the value field and if desired the field of other 
 general information (9a), settings of the

           select the right parameter in the parameter tree (9b).
       9. Enter the external ID of the parameter (9c).
     10. Click  (10).Apply
     11. The placeholder will be filled (11) in the content.

Please note:
To generate a preview of the replaced placeholder, the 
value needs to be filled independently of the setting that is 
used for the content of the placeholder.

Define placeholders manually
Click  below the list of the used placeholders (1).+
From the select list ( ) select Select placeholder type Parameter 

 (2). placeholderlinked General information
.Adjust the one or more parameter(s) (3)

Select one or more general information and their setting(s) (4, 
5).
Fill in a name between [[...]] (6).
Optional: configure delimiters for enumerations of included 
values (7).
Copy the name [[...]] into the content element (8).
Click Save.

 
Possible next steps

Adding a placeholder
Editing a placeholder
Removing a placeholder
Moving a content element
Adding notes to content elements
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Adding a parameter linked measurement 
placeholder

There are three different ways to add a parameter linked 
 to the :measurement placeholder content

 

Writing a content element
Write a string within a  starting with [[ and content element
ending with ]] (1)
Click somewhere outside the content element. A modal window 
opens confirming the new placeholder (2)
Click  and the placeholder will be added to the list (3)OK
From the select list ( ) select Select placeholder type Parameter 

 (4)linked Measurement placeholder
Adjust the parameter(s) for that the placeholder should be filled 
(5)
Adjust the measurement(s) (6a), select the setting(s) (6b). 
Optional: in case of , select the index Multiple input elements
(6c). More than one selected measurement with multiple input 
is currently not supported.
Optional: configure delimiters for enumerations of included 
values.
Click . Save

Reusing a content element
Adding content elements which contains parameter linked 
measurement placeholders
A modal window opens confirming the new placeholders (2)
Click  and the   OK new parameter linked measurement
placeholders will be added to the list (3)
From the select list ( ) select Select placeholder type Parameter 

 (4)linked Measurement placeholder
Adjust the parameter(s) for that the placeholder should be filled 
(5)
Adjust the measurement(s) (6a), select the setting(s) (6b). 
Optional: in case of , select the index Multiple input elements
(6c). More than one selected measurement with multiple input 
is currently not supported.
Optional: configure delimiters for enumerations of included 
values.
Click Save.

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > OperationsContent :  > Parameters Edit
Toolbar > Data > > OperationsContent :  > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > Data > > OperationsContent : Translate > Edit

Role
Content Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
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https://confluence.bio.logis.de/display/HBGIMS/Toolbar
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On the  tab:View

       8. Fill the value field and if desired the field of other 
settings of the measurement(s) (7a), select the right 
parameter in the parameter tree (7b)
       9. Enter the external ID of the parameter (7c)
     10. Click  (8)Apply
     11. The placeholder will be filled (9) in the content

Please note:
To generate a preview of the replaced placeholder, the 
value needs to be filled independently of the setting that is 
used for the content of the placeholder.

Define placeholders manually
Click  below the list of the used placeholders (1).+
From the select list ( ) select Select placeholder type Parameter 

 (2). placeholderlinked Measurement
.Adjust the one or more parameter(s) (3)

Select one or more measurement(s) and their setting(s) (4).
Fill in a name between [[...]] (5).
Copy the name [[...]] into the content element (6).
Optional: configure delimiters for enumerations of included 
values.
Click Save.

 
Possible next steps

Adding a placeholder
Editing a placeholder
Removing a placeholder
Moving a content element
Adding notes to content elements
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Editing a placeholder

Editing parameter 
placeholders
A  consists of three parts that can be parameter placeholder
modified:

Parameter : by default, is selected  but if it class  All parameters ,
is necessary to exclude  in the replacement, the parameters

 can be opened and a more specific class can parameter tree
be set.
Metadata field: by default,  is selected, but any Name metadata 

 can be selected.field
String: determines how the placeholder is labeled in the 

 A string has to start with [[ and end with ]].content element.
optional: style the entire placeholder name in the content 
element by using . The replaced placeholder text editor features
will be delivered in the desired style.
optional: configure delimiters for enumerations of included 
values.

To connect placeholders with different parameter classes or 
metadata fields, select other options in the placeholder list 
of the content attributes. 

Editing general information 
placeholders
A  consists of three parts general information placeholder
that can be modified:

General information: a list of all optional and required general 
information either listed with name or ID if no name is set. For a 
multiple selection hold  on your keyboard and select the Ctrl
general information of interest (1).

 information settingGeneral : by default,  is selected, but Value
any general information setting can be selected (2).
String: determines how the placeholder is labeled in the 

 A string has to start with [[ and end with ]]  (3).content element.

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > OperationsContent :  > Parameters Edit
Toolbar > Data > > OperationsContent :  > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > Data > > OperationsContent : Translate > Edit

Role
Content Editor
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optional: style the entire placeholder name in the content 
element by using . The replaced placeholder text editor features
will be delivered in the desired style.
optional: configure delimiters for enumerations of included 
values(4).

Editing measurement 
placeholders
A  consists of three parts general information placeholder
that can be modified:

Measurement: a list of all measurements either listed with 
name or ID if no name is set. For a multiple selection hold  Ctrl
on your keyboard and select the measurements of interest (1).

 settingMeasurement : by default,  is selected, but any ID
measurement setting can be selected (2).
String: determines how the placeholder is labeled in the 

 A string has to start with [[ and end with ]]  (3).content element.
optional: style the entire placeholder name in the content 
element by using . The replaced placeholder text editor features
will be delivered in the desired style.
optional: configure delimiters for enumerations of included 
values (4).

Editing parameter linked 
general information 
placeholders
A  consists parameter linked general information placeholder
of four parts that can be modified:

Parameter  or parameter: by default, is class  All parameters 
selected  but if it is necessary to exclude  in the , parameters
replacement, the  can be opened and a more parameter tree
specific class can be set (1).
General information: a list of all optional and required general 
information either listed with name or ID if no name is set. For a 
multiple selection hold  on your keyboard and select the Ctrl
general information of interest (2).

 information settingGeneral : by default,  is selected, but Value
any general information setting can be selected (3).
String: determines how the placeholder is labeled in the 

 A string has to start with [[ and end with ]]  (4).content element.
optional: style the entire placeholder name in the content 
element by using . The replaced placeholder text editor features
will be delivered in the desired style.
optional: configure delimiters for enumerations of included 
values (5).

Editing parameter linked 
measurement placeholders
A  consists of parameter linked measurement placeholder
four parts that can be modified:
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1.  

2.  

3.  

4.  

5.  

6.  

1.  

2.  

3.  

4.  

Parameter  or parameter: by default, is class  All parameters 
selected  but if it is necessary to exclude  in the , parameters
replacement, the  can be opened and a more parameter tree
specific class can be set (1).
Measurement: a list of all measurements either listed with 
name or ID if no name is set. For a multiple selection hold  Ctrl
on your keyboard and select the measurements of interest (2).

 settingMeasurement : by default,  is selected, but any ID
measurement setting can be selected (3).
String: determines how the placeholder is labeled in the 

 A string has to start with [[ and end with ]]  (4).content element.
optional: style the entire placeholder name in the content 
element by using . The replaced placeholder text editor features
will be delivered in the desired style.
optional: configure delimiters for enumerations of included 
values (5).

Editing rule-based 
placeholders
A  consists of four parts that can be rule-based placeholder
modified:

a rule-based placeholder can be replaced by another 
placeholder type
The exclusion set can be changed whereby the  placeholder
can be linked with other content
String: determines how the placeholder is labeled in the 

 A string has to start with [[ and end with ]].content element.
Content filled rule dependent into the placeholder can be 
changed or can be assigned to other rule-based placeholders 
by changing the exclusion set.

Please note:

frame the placeholder with {{[[ and ]]}} within the text to use it 
as an iterative placeholder
making rule-based placeholders iterative by adding curly 
braces is not supported
flexible placeholders can be edited in the   or content element

 by changing the content manuallytemplate

 
Possible next steps

Adding a placeholder
Editing a placeholder
Removing a placeholder
Moving a content element
Adding notes to content elements

https://confluence.bio.logis.de/display/HBGIMS/Flexible+placeholder
https://confluence.bio.logis.de/display/HBGIMS/Template
https://confluence.biologis.com/pages/viewpage.action?pageId=35750477
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Removing a placeholder

There are three different ways to remove a general or 
iterative  from the .placeholder content

Removing a content element
When all  which have contained a specific content elements

 are removed, the not needed placeholder  is set placeholder
empty. For details see Removing content elements from 

.content

Removing the string
When the placeholder string is removed in the content 

 containing the , the not needed element placeholder
 is set empty.placeholder

Removing from the list
If there is no  using this placeholder, the content element
string in the list of placeholders in the right sidebar can be 
set empty.

If there is still a  using this placeholder, a content element
modal window opens with an error message. After clicking 

, the placeholder will be added again to the list (1).OK

 

Removing a flexible 
placeholder
Flexible placeholders can be removed by deleting them in 
the content element or .template

 

How to get here

Default way:

Toolbar > Data >   > Operations: Content Edit

Other ways:

Toolbar > Data > Content > Operations: View > Edit
Toolbar > Data > > OperationsContent :  > Parameters Edit
Toolbar > Data > > OperationsContent :  > Workflow states
Edit
Toolbar > Data > Content > Operations: Settings > Edit
Toolbar > Data > > OperationsContent : Translate > Edit

Role
Content Editor

Possible next steps

https://confluence.biologis.com/display/HBGIMS/Template
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Parameter
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Adding a placeholder
Editing a placeholder
Removing a placeholder
Moving a content element
Adding notes to content elements

https://confluence.biologis.com/pages/viewpage.action?pageId=35750517
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Report orders
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Report orders overview

The list can be filtered by , ,  , Order ID Orderer Patient ID
,  and Request received since Response sent since

 (1).Processing status

The list shows the following information for each report order

 IDorder : the delivered ID of the order
orderer: the delivered name of e.g. the person or the institute 
that has ordered the content
requested report: the title of the   which has the content
delivered , linked to this content with selected uuid parameters
patient ID: the delivered ID of the patient for whom the content 
is ordered for
request time: time point of the last request
response time: time point of the last response
order action
processing status
operations: possible actions, for example view

The list can be sorted by clicking the corresponding title.

 

How to get here

Default way:

Toolbar > Data > Report orders

Role
Report Order Viewer

Possible next steps

Title link: Viewing content
View operation: Viewing the report order

https://confluence.bio.logis.de/display/HBGIMS/Role
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Viewing a report order

In addition to the information shown on the report orders 
 (1) the following information is displayed when overview

selecting a specific  (2)report order

General information: with their values and associated 
background information
Measurements: with their values and associated background 
information
Parameters: with their  and their internal nameexternal ID
optional Results: with basically transmitted values
optional Extracted Raw Data: with their raw values (further 
processed in variables)
optional KMM endpoints: with their data from the KMM
Processing log: gives information about the current processing 

 of the   (for details see ). status report order troubleshooting
Versions can be compared (3).

To view the content of a report order click on the Requested 
 (4). To identify the report order see the link with the report

 in the sidebar (5). Click on it to go back to the Order ID
overview (1,2,3).

Please note:

By changing values of general information, measurements 
and/or parameters the content does not reflect the ordered 
report anymore. (6).

 

How to get here

Default way:

Toolbar > Data >  > Report orders View

Role
Report Order Viewer

Possible next steps

Viewing content (the given parameters will be selected)
Editing the parameter
Editing metadata of the parameter

https://confluence.bio.logis.de/display/HBGIMS/Role
https://confluence.bio.logis.de/display/HBGIMS/Adding+and+editing+a+dummy+parameter
https://confluence.bio.logis.de/display/HBGIMS/Editing+metadata+of+a+parameter
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Self service upload portal
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1.  
2.  

3.  

Login

Log in
Enter the username
Enter the password (click on the 'eye symbol' in the password 
box to reveal or hide password)
Click Log in

Log out
In the Menu bar of any given page, click  (1).Log out
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1.  

2.  
3.  

Upload

Upload data
Drag and drop data file in the file section or click on the section 
(1) to browse through the data files on the computer and select 
one or more files to upload.
ID's of the patients selected for upload are listed (2).
The files selected for upload are listed (3).

Please note:

Multiple data files can be uploaded as described above. Valid 
formats are the xml, csv and vcf.
Once out of the upload page, the overview of the files will not 
be visible .anymore
A new upload will also overlay the data.
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1.  
2.  
3.  

Generate reports

Filter the file list to make your selection of patients for report 
generation:

Enter the Patient ID or
Enter the Request date
Click (1)Apply 

Set language/s for the reports:

the same for all patients from the  section Report language
above the grey line (2)
individually for each patient (3)

Generate the report/s:

for all patients at once by clicking the  Generate report
checkbox above the grey line(4)
individually by clicking  checkbox of each Generate report
patient (5)
click to generate the reports (6)Proceed 

Please note:

Clicking the checkboxes is only possible after the language 
selection for the report.
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1.  
2.  

Finalize reports

The list can be filtered by and Patient ID, Request date 
 (1).Generation status

When the Generation status is ' ' (2), the Report generated
report can be personalized:

Click in the column (3)Input Personalization 
Optionally, fill in the form with the required information for 
personalization of the report  and click S  (4)ubmit

When the Processing Status is ' (4)  the Report delivered' ,
report, the template for the Medication Safety Card and the 
cover letter with login data for the pharma.sensor app and 
webportal can be downloaded by clicking on the desired 
format (  and/or  (5).odt PDF

Please note:

Only patients with previously triggered report generation can be 
found in this list.
The type of generated report and the language in which it was 

 are displayed under the .generated Patient ID
Only for reports, whose generation are completed, the 'Input' 
button is enabled for personalization (7).
The data is saved and ready to download for 30 seconds, after 
which it is deleted.

The :Generation/Personalization Status

is depicted by an icon
can have different meanings

Generation status Personalization status

  Report generated

   Report generation in 
progress

   Error

  Report delivered

    Report in 
progress               

   Error
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1.  
2.  
3.  

1.  
2.  
3.  

Technical support

Request technical support
To send a support request:

click on the  icon (1) Support
the Service desk with the support categories is opened
type the issue in the designated section (3) or select a category 
(4) and fill in the form

Using the manual
To find a giudance for using the Self service upload portal:

click on the  icon (2)Manual
the manual ist opened (PDF)
check the detailed handling of the system to find a request 
answer

Please note :

The and icons can be found on every page Support Manual 
in the lower left corner.
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Administrator Manual DRM
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Configuring users
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Viewing user list

The list can be filtered by name, email, , permission and role
status (1).

The list shows the following information for each user

Username
Status: active or blocked
Roles
Member for: time since account creation
Last access: time since last login
Operations: possible actions, for example Edit

The list can be sorted by clicking the corresponding title 
(available username, status and last access).

Please note:

The function is only available if you own the role 'User 
Administrator'.

 

How to get here

Default way:

Toolbar > Manage > People

Role
User Administrator

Possible next steps

Adding an user account
free
Viewing user profile
Editing user profile
Editing password
Editing user profiles
Editing user passwords

https://confluence.biologis.com/display/HBGIMS/free
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1.  
2.  
3.  
4.  
5.  

Editing user passwords

Enter the new password into Password
The password strength shows the quality of the new password
Repeat the new password into Confirm password
It is shown whether the passwords are equal
Click Save

 

How to get here

Default way:

Toolbar > Manage > People > Operations: Edit

Other ways:

Toolbar > Manage >   > username > People Edit

Role
User Administrator

Possible next steps

View tab: Viewing the profile

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.biologis.com/display/HBGIMS/free
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Editing user profiles

Modify the following settings

E-mail address
Username
Password
Status
Roles
Language settings
Local settings

Click Save.

Please note:

The function is only available if you own the role 'User 
Administrator'.

  

 

How to get here

Default way:

Toolbar > Manage > People > Operations: Edit

Other ways:

Toolbar > Manage >   > username > People Edit

Role
User Administrator

Possible next steps

Editing user passwords
Viewing the profile

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
https://confluence.biologis.com/display/HBGIMS/free
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Adding an user account

Enter the required settings

Username
Password
Confirm password

Optional settings are

Email address
Status
Roles
Language settings
Locale settings

Click .Create new account

A message about the account creation is displayed.

Please note:

The function is only available if you own the role 'User 
Administrator'.

 

How to get here

Default way:

Toolbar > Manage > > People  Add user

Role
User Administrator

Possible next steps

Viewing the profile

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.biologis.com/display/HBGIMS/free
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Configuring new content types

New content types can be configured when documents with 
 a specific setting of sections are used more frequently. The 

sections can also be configured specifically for this content 
type.

1. Click  (1)+ Add clinical report type

2. Enter the name of the content type. Optionally add a 
description, change the processor chain and link a template 
for this content type (2).

3. To configure the sections for the new content type, click 
 (3).+Default sections

4. Click  (4) and select the desired section. Add another item
Repeat this process until all sections are in the list.

5. Click (5).Save configuration'

6. Optional: to change the attributes of a section only for this 
content type, click  (6). +Configure sections
    Click (7) for the desired section and make changes Edit 
of the section attributes (8).

How to get here

Default way:

Toolbar > Manage > Structure > Content types 

Role
Content Type Administrator
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7. The new content type is now available for adding of new 
 (9).contents
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Possible next steps

Content overview
Adding new content
Configuring sections
Configuring workflows
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Configuring content
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Setting the used workflow
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1.  
2.  

Setting the workflow of contents

Select the  to use (1).workflow
Click Save.

 

How to get here

Default way:

Toolbar > Data >   > Operations: Content Settings

Other ways:

Toolbar > Data > Content > Operations: View > Settings
Toolbar > Data > > OperationsContent : > Edit Settings
Toolbar > Data > > OperationsContent :  > Workflow states
Settings
Toolbar > Data > Content > Operations: > Parameters 
Settings
Toolbar > Data > > OperationsContent : Translate > 
Settings

Role
Content Settings Editor

Possible next steps

Setting the workflow of content elements
Editing the content
Viewing the parameters of the content
Viewing the workflow states of the content
Translating the content

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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1.  
2.  

Setting the workflow of content elements

Select the  to use (1).workflow
Click Save.

 

How to get here

Default way:

Toolbar > Data >  > Text/Media elements
Operations: Settings

Other ways:

Toolbar > Data >   > OperationsText/Media elements : View 
> Settings
Toolbar > Data >  > Operations Text/Media elements : Edit 
> Settings
Toolbar > Data >  > Operations Text/Media elements : 

 > Workflow states Settings
Toolbar > Data >   Text/Media elements > Operations: 

> Parameters Settings
Toolbar > Data >  > Operations Text/Media elements : 
Translate > Settings

Role
Content Element Settings Editor

Possible next steps

Editing the setting of the content
Editing the content
Viewing the parameters of the content
Viewing the workflow states of the content
Translating the content

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role


Manual GIMS 1.12

206

1.  
2.  

Setting the used template

Select the  by adding the filename (1).template
Click Save.

 

How to get here

Default way:

Toolbar > Data >   > Operations: Content Settings

Other ways:

Toolbar > Data > Content > Operations: View > Settings
Toolbar > Data > > OperationsContent : > Edit Settings
Toolbar > Data > > OperationsContent :  > Workflow states
Settings
Toolbar > Data > Content > Operations: > Parameters 
Settings
Toolbar > Data > > OperationsContent : Translate > 
Settings

Role
Content Settings Editor

Possible next steps

Generating a report preview
Editing the setting of the content
Editing the content
Viewing the parameters of the content
Viewing the workflow states of the content
Translating the content

https://confluence.biologis.com/display/HBGIMS/Template
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Generating+a+report+preview
https://confluence.bio.logis.de/display/HBGIMS/Setting+the+used+workflow
https://confluence.bio.logis.de/display/HBGIMS/Editing+contents
https://confluence.bio.logis.de/display/HBGIMS/Viewing+the+parameters+of+a+content
https://confluence.bio.logis.de/display/HBGIMS/Viewing+the+workflow+states+of+a+content
https://confluence.bio.logis.de/display/HBGIMS/Translating+contents
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1.  
2.  
3.  
4.  

5.  

Default setting of general information

Choose between  and .Required Protected General Information
Click on .New General Information
Obligatory: add the laboratory specific ID.
Optional: add Status, Description, Domain, Name.
Please note:  Information are deposited here as default. If other, 
individual information are transmitted from the LIMS, these are 
used in the content.
If no individual information are transferred, the DRM verifies 
whether a default is deposited and adds it to the data of this 
case.
Click .Save

 

How to get here

Default way:

Toolbar > Data >   > Operations: Content Settings

Other ways:

Toolbar > Data > Content > Operations: View > Settings
Toolbar > Data > > OperationsContent : > Edit Settings
Toolbar > Data > > OperationsContent :  > Workflow states
Settings
Toolbar > Data > Content > Operations: > Parameters 
Settings
Toolbar > Data > > OperationsContent : Translate > 
Settings

Role
Content Settings Editor

Possible next steps

Editing the setting of the content
Editing the content
Viewing the parameters of the content
Viewing the workflow states of the content
Translating contents

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Setting+the+used+workflow
https://confluence.bio.logis.de/display/HBGIMS/Editing+contents
https://confluence.bio.logis.de/display/HBGIMS/Viewing+the+parameters+of+a+content
https://confluence.bio.logis.de/display/HBGIMS/Viewing+the+workflow+states+of+a+content
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1.  
2.  
3.  

4.  

5.  

Default setting of measurements

Choose between  or (1). Required Optional Measurements
Click on (2).New Measurement 

Deposit the default settings:

Obligatory: add the laboratory specific  (3).ID
Optional: add , , ,  (4).Status Description Domain Name
Optional: add  and/or  for the expected value Unit Percentage
(5).
Optional: add  and/or for a single Value, Unit Percentage 
reference value ( 6a) or for a reference range (Discrete, 

6b).Minimum - Maximum, 
Optional: add  and/or for (7). Unit Percentage Preceding Values 

Please note: All optional information are deposited here as 
 default. If other, individual information or values are 

 transmitted from the LIMS, these are used in the content. If 
no individual information are transferred, the DRM verifies 
whether a default is deposited and adds it to the data of this 
case.

Click .Save

How to get here

Default way:

Toolbar > Data >   > Operations: Content Settings

Other ways:

Toolbar > Data > Content > Operations: View > Settings
Toolbar > Data > > OperationsContent : > Edit Settings
Toolbar > Data > > OperationsContent :  > Workflow states
Settings
Toolbar > Data > Content > Operations: > Parameters 
Settings
Toolbar > Data > > OperationsContent : Translate > 
Settings

Role
Content Settings Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
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Possible next steps

Editing the setting of the content
Editing the content
Viewing the parameters of the content
Viewing the workflow states of the content
Translating the content

https://confluence.bio.logis.de/display/HBGIMS/Setting+the+used+workflow
https://confluence.bio.logis.de/display/HBGIMS/Editing+contents
https://confluence.bio.logis.de/display/HBGIMS/Viewing+the+parameters+of+a+content
https://confluence.bio.logis.de/display/HBGIMS/Viewing+the+workflow+states+of+a+content
https://confluence.bio.logis.de/display/HBGIMS/Translating+contents
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1.  

2.  

Setting the used processor chain

Select the desired  from the dropdown menu processor chain
(1).
Click Save.

 

How to get here

Default way:

Toolbar > Data >   > Operations: Content Settings

Other ways:

Toolbar > Data > Content > Operations: View > Settings
Toolbar > Data > > OperationsContent : > Edit Settings
Toolbar > Data > > OperationsContent :  > Workflow states
Settings
Toolbar > Data > Content > Operations: > Parameters 
Settings
Toolbar > Data > > OperationsContent : Translate > 
Settings

Role
Content Settings Editor

Possible next steps

Editing the setting of the content
Editing the content
Viewing the parameters of the content
Viewing the workflow states of the content
Translating the content

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Configuring workflows
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Overview of workflows

The list shows the available workflows for all components in 
the system.

Content elements
Content
Report Template

For each  the following information is shown:workflow

label
operations: possible actions, for example edit

 

How to get here

Default way:

Toolbar > Manage > Workflows

Role
Workflow Editor

Possible next steps

Adding a new workflow
Editing a workflow

https://confluence.biologis.com/display/HBGIMS/Template
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Editing a workflow

The following options are available for editing workflows:

Label: how the workflow is labeled in the overview of workflows
Workflow graph: click the  button to Edit edit the workflow graph
Change class: changes of workflow states based on saving of 
modification in the content. Minor or major change can induce 
different workflow states for the parameter combinations. Define
here whether and how far the affected parameter combination 
is reverted in the review process.

Minor changes are recommended for small changes 
such as spelling mistakes etc.
Major changes are recommended for adding new 
content or reorganization etc.

for each combination of current  and change class the new state
 of the state content

State for new: the default workflow state
State for publishing: the  a   has to have in workflow state content
order to be delivered
Transition: which  an  has to have in order to role user change 
the workflow state of a content
Show a log message field when changing the workflow state of 
an entity: for each workflow state change it is possible to leave 
a message  (1)
Fallback behavior: 3 different states selectable for the 
publishing behavior of content elements in this document after 
changing

Do not fallback (default)
Fall back to the newest published revision
Fall back to the translation source if that is published

Click .Save

 

      

How to get here

Default way:

Toolbar > Manage >  >  Workflows Edit

Other ways:

Toolbar > Manage >  >   > Workflows Edit Workflow 
 > Graph Edit > Back to workflow

Role
Workflow Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

View a workflow graph
Overview of workflows
Adding a new workflow
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1.  
2.  

3.  
4.  

5.  

6.  

7.  

Adding a new workflow

Enter the label (1).
Select the type of components the workflow will be used for. 
For example  should be used for clinical reports, Content
recommendations, etc. (2).
Select the  to be used (3). workflow graph
Decide whether the selected  should be used workflow graph
directly, or if a copy should be generated (4).
Optional: In case a new copy of the selected  is workflow graph
generated, give it its own label (4).
Optional: Choose to show a text area to allow tracking the 
rationale behind a workflow state change (5).
Click Save.

 

How to get here

Default way:

Toolbar > Manage >  >  Workflows Add workflow

Role
Workflow Editor

Possible next steps

View a workflow graph
Overview of workflows
Editing a workflow

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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View a workflow graph

The  is predefined. Therefore, four workflow graph Default
workflow states are fixed, they can be renamed but they 
cannot be deleted. Arrows determine the chronological 
procedure of the workflow states. The  can workflow graph
be dragged and zoomed in.

To return to  click .workflow Back to workflow

To modify the workflow graph see .Editing a workflow graph

 

How to get here

Default way:

Toolbar > Manage >  > Workflows Edit

Role
Workflow Editor

Possible next steps

Adding a new workflow state
Renaming a workflow state
Moving a workflow state
Removing a workflow state
Adding a new workflow transition
Renaming a workflow transition
Moving a workflow transition
Removing a workflow transition

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Editing a workflow graph
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1.  
2.  

3.  

Adding a new workflow state

Click (1)Add Node 
Click in an empty space into the workflow graph to place the 
new node.
A  with the label  appears (2)workflow state new

Note: the default  are displayed orange, workflow states
the custom  are displayed blue.workflow states

Click  to keep the changes or  to discard them.Save Reset

How to get here

Default way:

Toolbar > Manage >  >   > Workflows Edit Workflow 
 > Graph Edit

Role
Workflow Editor

Possible next steps

View a workflow graph
Renaming a workflow state
Moving a workflow state
Removing a workflow state
Adding a new workflow transition
Renaming a workflow transition
Moving a workflow transition
Removing a workflow transition

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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1.  
2.  
3.  

Renaming a workflow state

Double click the  new workflow state
In the modal window, enter the new name (1)
Click Apply

Click  to keep the changes or  to discard them.Save Reset

How to get here

Default way:

Toolbar > Manage >  >   > Workflows Edit Workflow 
 > Graph Edit

Role
Workflow Editor

Possible next steps

View a workflow graph
Adding a new workflow state
Moving a workflow state
Removing a workflow state
Adding a new workflow transition
Renaming a workflow transition
Moving a workflow transition
Removing a workflow transition

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow
https://confluence.bio.logis.de/display/HBGIMS/Workflow+graph
https://confluence.bio.logis.de/display/HBGIMS/Workflow+graph
https://confluence.bio.logis.de/display/HBGIMS/Role
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Moving a workflow state

The  can be moved by dragging it.workflow state

Click  to keep the changes or  to discard them.Save Reset

How to get here

Default way:

Toolbar > Manage >  >   > Workflows Edit Workflow 
 > Graph Edit

Role
Workflow Editor

Possible next steps

Adding a new workflow state
Renaming a workflow state
View a workflow graph
Removing a workflow state
Adding a new workflow transition
Renaming a workflow transition
Moving a workflow transition
Removing a workflow transition

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow
https://confluence.bio.logis.de/display/HBGIMS/Workflow+graph
https://confluence.bio.logis.de/display/HBGIMS/Workflow+graph
https://confluence.bio.logis.de/display/HBGIMS/Role
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1.  
2.  

Removing a workflow state

Click on the  custom workflow state
Click on (1)Delete selected 

Click  to keep the changes or  to discard them.Save Reset

Note: Only blue custom  can be deleted. The workflow states
orange predefined workflow states can not be deleted.

How to get here

Default way:

Toolbar > Manage >  >   > Workflows Edit Workflow 
 > Graph Edit

Role
Workflow Editor

Possible next steps

Adding a new workflow state
Renaming a workflow state
Moving a workflow state
View a workflow graph
Adding a new workflow transition
Renaming a workflow transition
Moving a workflow transition
Removing a workflow transition

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow
https://confluence.bio.logis.de/display/HBGIMS/Workflow+graph
https://confluence.bio.logis.de/display/HBGIMS/Workflow+graph
https://confluence.bio.logis.de/display/HBGIMS/Role
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1.  
2.  
3.  

Adding a new workflow transition

Click (1)Add Edge 
Click the  where the new link should startworkflow state
 Drag the   to another workflow transition workflow state to 
connect them

Click  to keep the changes or  to discard them.Save Reset

 

How to get here

Default way:

Toolbar > Manage >  >   > Workflows Edit Workflow 
 > Graph Edit

Role
Workflow Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow
https://confluence.bio.logis.de/display/HBGIMS/Workflow+graph
https://confluence.bio.logis.de/display/HBGIMS/Workflow+graph
https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

Adding a new workflow state
Renaming a workflow state
Moving a workflow state
Removing a workflow state
View a workflow graph
Renaming a workflow transition
Moving a workflow transition
Removing a workflow transition
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1.  
2.  
3.  

Moving a workflow transition

Click the workflow transition
Click Edit Edge (1)
Click one endpoint of the  and drag it to workflow transition
another workflow state

Click  to keep the changes or  to discard them.Save Reset

How to get here

Default way:

Toolbar > Manage >  >   > Workflows Edit Workflow 
 > Graph Edit

Role
Workflow Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow
https://confluence.bio.logis.de/display/HBGIMS/Workflow+graph
https://confluence.bio.logis.de/display/HBGIMS/Workflow+graph
https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

View a workflow graph
Adding a new workflow state
Renaming a workflow state
Moving a workflow state
Removing a workflow state
Adding a new workflow transition
Renaming a workflow transition
Removing a workflow transition
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1.  
2.  

Removing a workflow transition

Click the workflow transition
Click (1)Delete selected 

Click  to keep the changes or  to discard them.Save Reset

How to get here

Default way:

Toolbar > Manage >  >   > Workflows Edit Workflow 
 > Graph Edit

Role
Workflow Editor

Possible next steps

View a workflow graph
Adding a new workflow state
Renaming a workflow state
Moving a workflow state
Removing a workflow state
Adding a new workflow transition
Renaming a workflow transition
Moving a workflow transition

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow
https://confluence.bio.logis.de/display/HBGIMS/Workflow+graph
https://confluence.bio.logis.de/display/HBGIMS/Workflow+graph
https://confluence.bio.logis.de/display/HBGIMS/Role
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1.  
2.  
3.  

Renaming a workflow transition

Double click the workflow transition
In the modal window, enter the new name
Click Apply

Click  to keep the changes or  to discard them.Save Reset

How to get here

Default way:

Toolbar > Manage >  >   > Workflows Edit Workflow 
 > Graph Edit

Role
Workflow Editor

Possible next steps

View a workflow graph
Adding a new workflow state
Renaming a workflow state
Moving a workflow state
Removing a workflow state
Adding a new workflow transition
Moving a workflow transition
Removing a workflow transition

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow
https://confluence.bio.logis.de/display/HBGIMS/Workflow+graph
https://confluence.bio.logis.de/display/HBGIMS/Workflow+graph
https://confluence.bio.logis.de/display/HBGIMS/Role
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Configuring custom styles
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Custom styles overview

The list shows the available  that can be used custom styles
for editing text. For each custom style the following is shown:

Label
ID: Used to define styling in templates.
HTML class: Any text to which a custom style is applied will 
receive the respective class in the generated report.
Color: Used to mark any text visible with a custom style in the 

 and  mode.Edit View
Operations: Possible actions, for example   orEdit  Delete.

The list of custom styles can also be reordered by using 
drag-and-drop.
The order of the custom styles in the overview determines 
the order of custom styles displayed in the dropdown menu 
in  in the  mode.content elements Edit

How to get here

Default way:

Toolbar > Manage > Configuration > Custom styles

Role
Custom Style Editor

Possible next steps

Adding a new custom style
Editing a custom style
Deleting a custom style
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1.  

2.  

3.  

4.  

Adding a new custom style

Enter the . The custom style will be available in the user Label
interface with this name.
Enter the  The HTML class is needed to identify HTML Class.
the custom style when transferring it between different 
systems. It is suggested to use lowercase words connected 
with hyphens (e.g. Label: Product name, HTML class: product-
name).
Select the . The custom style will be delivered in the user Color
interface with this color.
Click  .Save

How to get here

Default way:

Toolbar > Manage > Configuration > Custom styles
> Add custom style

Role
Custom Style Editor

Possible next steps

Custom styles overview
Editing a custom style
Deleting a custom style

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Custom+style
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Editing a custom style

Following features can be edited:

label: How the custom style is labeled in the custom styles 
overview.
HTML class: The class that will be used for the custom style in 
the generated reports.
color: The color that will be used to mark the custom style in 
the user interface.

Click  .Save

How to get here

Default way:

Toolbar > Manage > Configuration > Custom styles
> Operations: Edit

Role
Custom Style Editor

Possible next steps

Deleting a custom style
Custom styles overview

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Custom+style


Manual GIMS 1.12

233

Deleting a custom style

Click  to remove a custom style from the list of the Delete
dropdown menu of availlable styles in the  content elements
in the text editor. Text marked with this style will not longer 
be labelled.

If you are certain you want to delete this style, click  .Delete

How to get here

Default way:

Toolbar > Manage > Configuration > Custom styles
Operations:>  Delete

Other ways:

Toolbar > Manage > Configuration > Custom styles
> Operations: Edit > Delete

Role
Custom Style Editor

Possible next steps

Adding a new custom style

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Custom+style
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Custom+style
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Configuring sections
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Sections overview

The list shows the available  that can be integrated sections
within content. For each section the following is shown:

label: how the section is called within DRM
machine name: how the section is identified outside DRM (e. g. 
in , in LIMS)templates
operations: possible actions, for example Edit

How to get here

Default way:

Toolbar > Manage > Configuration > Sections 
> Available sections

Role
Section Configurator

Possible next steps

Adding a new section
Editing a section

https://confluence.biologis.com/display/HBGIMS/Template
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Adding a new section

click  (1)+ Add section 
enter the label of the  (2)section
the  will be generated automatically,machine name
optional: the machine name can be edited by clicking (2a)Edit 
select the relevance (3)
select the display (feature not implemented yet) (4)
click  (5)Save 

How to get here

Default way:

Toolbar > Manage > Configuration > Sections 
> Available sections

Role
Section Configurator

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
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Possible next steps

Set default set of sections for new content
Adding a section to content
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Editing a section

enter the label (1)
select the relevance to determine whether it has to be included 
in checks for completeness (2)

Included in checks for completeness: 
the section contains the main information of the 
content.
a warning is displayed if the content of the section is 
integrated in the document that shall be incompletely 
generated 
e.g. required general information are not delivered. In 
this case a warning is shown and therefore the report 
is not generated.

Not included in checks for completeness
the section only contains additional information.
a warning is never generated. Content is also 

.delivered when parts of the section are missing

select the display (feature not implemented yet) (3)
Choose  if the section should always be fully shown when Full
viewing or editing the content.
Choose  if the section should only be opened when Folded
needed.
click  (4)Save 

How to get here

Default way:

Toolbar > Manage > Configuration > Sections 
> Available sections > Edit

Role
Section Configurator

Possible next steps

Sections overview
Adding a new section
Integrating content

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
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Set default set of sections for new content

Define which set of sections shall be used for new  content
per default. Already existing content is not affected by 
changes made here.

select the content type (1)
optional: rearrange the sections by drag-and-drop
optional: remove a sections by removing its label
optional:add another section by clicking  and Add another item
using the autocomplete box (note: only sections listed in 

can be used) (2)sections overview 

Click (3)Save configuration .

How to get here

Default way:

Toolbar > Manage > Configuration > >  Sections 
Default sections

Role
Section Configurator

Possible next steps
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Adding a section to content
Editing a section
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1.  
2.  
3.  

Adding a section to content

Select the new  (1)section
Optional: rearrange the sections by drag and drop
Click (2)Save 

Note: only sections listed in  can be overview of sections
used. If the section is not available yet, see Adding a new 

.section

 

How to get here

Default way:

Toolbar > Data >   > Operations: Content Settings

Other ways:

Toolbar > Data > Content > Operations: View > Settings
Toolbar > Data > > OperationsContent : > Edit Settings
Toolbar > Data > > OperationsContent :  > Workflow states
Settings
Toolbar > Data > Content > Operations: > Parameters 
Settings
Toolbar > Data > > OperationsContent : Translate > 
Settings

Role
Content Settings Editor

Possible next steps

Editing the setting of the content
Editing the content
Viewing the parameters of the content

https://confluence.bio.logis.de/display/HBGIMS/Overview+of+sections
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Viewing the workflow states of the content
Translating the content
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1.  
2.  

Removing sections from existing content

Delete the name of the section to be removed (1,2)
Click Save

Please note:
To remove a section from existing content the section 
should not contain any content boxes in all translations, 
otherwise the deletion is disabled (3). A message is created 
describing why the section could not be reconfigured.

How to get here

Default way:

Toolbar > Data >   > Operations: Content Settings

Other ways:

Toolbar > Data > Content > Operations: View > Settings
Toolbar > Data > > OperationsContent : > Edit Settings
Toolbar > Data > > OperationsContent :  > Workflow states
Settings
Toolbar > Data > Content > Operations: > Parameters 
Settings
Toolbar > Data > > OperationsContent : Translate > 
Settings

Role
Content Settings Editor

https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Workflow+state
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Toolbar
https://confluence.bio.logis.de/display/HBGIMS/Role
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Possible next steps

Editing the setting of the content
Editing the content
Viewing the parameters of the content
Viewing the workflow states of the content
Translating the content
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FAQ DRM

1) Why is it possible to  select contradictory 
parameters simultaneously?
On a  it is possible to select several  at the same time even though they might contradict with each parameter tree, parameters
other (e.g. selecting parameters 'homozygous' and 'heterozygous'). This feature is designed purposefully to achieve the following:

a) the user can define   as ‘at least two’ of the given  even though they are contradictory with each otherrules parameters

b) contradictory  can exist in context with parameters exclusions sets

c) the user is able to identify any erroneous data that might have possibly landed in DRM from LIMS/LIS. 

2)  Can I display a final layout of my content in the 
view tab?
In the view tab, you can select report order values and observe how this affects the display of the corresponding content boxes. 
You can either walk through different sections or choose display sections as show all. Generating a preview enables you to take 
a look at how your content will be integrated to your template for the selected report order values. On the other hand, the final 
layout depends on the receiving system (e.g. LIMS) that is unknown to GIMS. bio.logis GIM provides an add-on, Report Layout 
Engine (RLE), which serves as a 'content to layout converter'. Together with RLE and DRM you can request a final layout at your 
receiving system. This way, differently than generating a preview, you can also include patient specific data (possibly encryted
/decrypted) in your final layout.

3)  Why should I use text editor features in content 
elements?
Defining various text editor features (e.g. bold, superscript, heading 3) in a given content box will mark the text for a matching 
format in final layout.

4) Why do I get an error message for setting my 
heading formats incorrectly?
Heading format can only be set following specific guidelines. Please follow the heading formating instructions described in 

.Formats



Manual GIMS 1.12

246

5) Why are the references allocated to a content 
box and not to a content element?

 can only be listed in a and not in a . This is to ensure that one content element with References  content box content element
specific references is not erroneously reused in an unrelated . References are placed in content boxes in a content-content
specific manner.

6) Why do only certain content boxes/elements 
automatically open in the Edit tab?
When switching from the View tab to the Edit tab, certain content elements/boxes automatically open. This reflects a certain 
selection of report order values in the View tab. Content boxes with the rule 'Always true' are always open in the edit tab.

7) How do I integrate personal information such as 
an indication into my report?
To integrate personal information into the delivered content a GIMS-LIMS interface is required.  can be sent General information
from LIMS to GIMS and can be directly included into  in the report.flexible placeholders

8)  How can I use DRM in a time-efficient manner, 
especially when there is a constant flow of new 
genetic variants?
You can avoid generating new rules,  trees, s every time a new variant arrives in DRM. For this, you parameter content element
should order the  in your parameter tree with variants as different parameters. Next, you should use these classes to classes
associate your content boxes with appropriate rules. The new variant can then be sorted as a new parameter in this tree. This 
way it is automatically involved with the corresponding rules/content boxes, which will in turn save time.

?9) How can I delete rows or columns in a table
Right-click into a table cell within the row or column, you want to delete. Select  / and click / Row Column Delete Row Delete 
Column. Please note that this does not alter the cells of the header

10) Why is the outdated mark  autnot set omatically 
 after editing a text element?r translationsfo

GIMS has been configured to handle translations independently, .  no synchronous processing is dictated after translation This 
s that not exactly the same number of  must be specified in all translations. guarantee content elements In support of this 
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flexibility, the exact number of content elements in all the is not specified, but this also makes a direct link translations outdated 
impossible. An automatic outdated labelling is not wanted, since it does not distinguish between changes in content and linguistic 

.reformulations which concern only one language

11) Why do I have a non-replaced placeholder in 
the View tab?
Placeholders are replaced by their corresponding metadata ( when their additional information like description, ID, name etc.) 
values are also applied. For example when the value (e.g. parameter value: LCT c.13910 T>C: hom) is missing the link to the 
metadata (e.g. phenotype: pathogenic) and hence the placeholder is also missing.

) Why is my newly created tag/content element12
/translation not displayed in the search list?
It takes 5 to 10 minutes until newly created content appears in the search lists of the DRM. In case content is not displayed after 
10 minutes, please check whether you have created your content correctly.

) 13 I would like to reuse one of my content 
elements by drag and drop. Why is it not displayed 
in the content box I have chosen?
The content element needs to be dropped exactly into the chosen content box. If it is dropped on the title or other areas of the 
content box, the content element might not be detected. In this case it would not be displayed.

) Why14  are   prefilled and report order values
inactivated in the View tab?
In case identical variables are shared among contents that are integrated, values s where are taken over in downstream content
they can not be changed. The entered values of these variables are saved even on the  tab of another content. Thus, values View
might be set already  and previously set variables are locked until clicking the clear button.in an integrated content

) 15 When I am generating new computed general 
information or measurements, why is it not 
possible to set any dummy values for them?
GIMS DRM can compute general information and measurements based on other variables (e.g. sex can be computed via 
karyotype). For this reason it would be irrelevant to set any dummy value. Therefore dummy values are hidden when generating 
a computed general information or measurement.



Manual GIMS 1.12

248

Glossary DRM
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Barcode element
Barcode element is a content element, which is converted 
into a QR code during report generation.

contains plain text
can include  (iterative and flexible placeholders  placeholders
are not supported)
can be tagged
can have notes
can be translated
can be embedded in different sizes and positioning in the 
content
does not support text editor features
can wrap following content elements
editing history can be traced at Revisions tab
translations can be marked as outdated
located on  within a  content content box

 on the content view (as adisplayed  barcode preview)
read with a barcode scanner app

Mentioned in

Adding content elements
Content element

 

 

Tip

Barcode elements can link to websites directly.



Manual GIMS 1.12

250

Change class
The change class describes the type of change that has 
been made.

 

defined when saving  or  while editing content content element
content
possible values: minor, major
depending on the predefined  for minor and major workflows
class saving can lead to a change of the workflow state for the 
selected and all other affected parameter combinations

Mentioned in

Editing a content element
Translating content elements
Editing content
Editing a workflow
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Class
A class is a set of .parameters

created by the user
depicted with a closed folder in the parameter tree
in each content, a preset class with all relevant All parameters 
parameters
can be translated
does not contain newly set parameters
can be edited to make visible or invisiblemetadata fields 
can be operated by rules

 can use  of a classplaceholders metadata

Mentioned in

Replacing a dummy parameter
Adding and editing parameters
Setting the rule of a content box
Adding and editing a class
Parameter overview
Editing a placeholder
Generating a parameter tree

Tip

It is recommended that the  only contain rules
classes and no explicit . This saves time parameter
writing   for new , when they only content parameters
need to be sorted into their class.
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Content
The content is a document, where all contents for a topic is 
managed. It defines what is delivered for a .report order

identified by its UUID
has a content type
applying report order values determines content outputs
consists of several sections
can be translated
editing history can be traced at Revisions tab
can be locked (when opened by one user Edit, Parameter, 
Settings tabs are blocked for other users for 30 minutes; 
translations are not affected)

Mentioned in

Editing content
Viewing content
Report orders overview
Inactivating a content box
Translating contents
Viewing content history
Content overview
Editing a content element
Adding content elements
Editing a placeholder
Adding a new metadata field
Editing a workflow
Removing content elements from content
Content locking

Tip

Use a new content for each clinical question.
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Content box
A content box is a space where you can place one or more 

 ( ,  or  elements)content elements text media barcode
 

found under a   of the section content
can have at title (if no title has been deposited, the title of the 
top content element of the content box is displayed)
has a rule
can have references
can be set inactive and not used in report generation even 
though its rule is fulfilled

inactive content boxes are marked by faded color in 
the  modeEdit

can belong to an exclusion set
can include  of other sections contents

 can be set includable and displayed as replacement for a rule-
based placeholder
can have a  for further styling on report generation CSS class

Mentioned in

Adding a content box to content
Viewing content
Moving a content box
Using similar content elements
Editing content
Translating contents
Adding content elements
Setting an exclusion set to a content box
Removing a content box from content
Setting references to a content box
Setting the rule of a content box
Inactivating a content box
Integrating content
Adding a placeholder
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Content element
A content element is the smallest unit of the . There content
are  types of content elements: , three text elements media 

 and .elements barcode elements

is located on  within a content content box
 be arranged side by sidemultiple content elements can

can have notes
editing history can be traced at Revisions tab
can be marked as outdated
can be moved to other content boxes
can have tags
in case of , the conflicts can be resolved concurrent editing
individually

Mentioned in   

Viewing notes of content elements
Editing content
Moving a content element
Editing a content element
Using similar content elements
Adding content elements
Setting an exclusion set to a content box
Editing a placeholder
Translating contents
Viewing content elements
Removing content elements from content
Managing content element revisions
Adding notes to content elements
Translating content elements
Publishing content element
Working with tags

Tip

In order to increase the reusability of content 
elements, it is recommended that the text contains 
only one statement.
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Content integration
Content integration enables the insertion of  of other sections
contents into a defined position in the present content.

allows management of frequently modified   content elements in 
 (e.g.one place  header, footer or sidebar of modifications on a 

 a clinical report can be managed by integrating them as page 
)fragments

 can be sh  more than one contentsections ared between
filled with metadata from integrated sections are placeholders 

transferred identically into the target content

Mentioned in

Integrating content
Page fragment

Tip

 integration allows separate management Content
of report fragments. These independent fragments 
can later be assembled into a comprehensive 
clinical report.



Manual GIMS 1.12

256

Content type
A content type describes the kind of  and provides content

 of default settings.configuration
 

default is Clinical report
has its own   configurationsection
has its own  configuration template
has its own configuration of processor chains
creation and configuration can only be done by an administrator

Mentioned in

Adding new content
Content overview

https://confluence.biologis.com/display/HBGIMS/Template
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CSS class
A CSS class provides additional styling information for the 
report generation on a .content box

special feature which can be enabled on request
the CSS class will be added to the output after the report is 
generated so additional styling can be done

Mentioned in:

CSS classes

https://confluence.biologis.com/display/HBGIMS/CSS+classes
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Custom style
Custom styles allow to mark up parts of a text in text 

 or captions of  with custom styling.elements media elements

can be added or edited by the custom style editor
is avialable in the t es > styles of content ext editor featur
element
has an associated color that is used to mark up the phrase in 
the content element.
Please note: Coloring is only a tool for the user to find the 
custom styled words more easily in the text. It does not 
correspond to the final format.
marking a phrase with a custom style allows a special 
formatting for this text area by the Report Layout Engine 
or requesting system (e.g. LIMS, LIS)

Mentioned in

Styles
Configuring custom styles

Tip

Using custom styles enables a more individual 
formatting of .content elements
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Exclusion set
An exclusion set is a group of mutually exclusive content 

.boxes
 

not mandatory to use but recommended as it provides 
additional validation on the content
indicates contradictory content
if more than one of an exclusion set has its  content box rule
fulfilled, the report will not be processed
each exclusion set has its own colored symbol

Mentioned in

Setting an exclusion set to a content box
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External ID
The   a .external ID identifies parameter  

is given by the ordering system (e.g. LIMS, LIS)
cannot be set manually
arbitrary string of up to 20 characters
if an unknown external ID is received, a corresponding 

 is createdparameter

Mentioned in

Viewing a report order
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Format
In addition to , formats allow an improved sections
structuring of the  in  which can be content text elements
interpreted by the receiving system.

available formats: Normal and Heading 1 to 6
a   may contain text element maximum one heading
a   may not contain normal text together with a text element
heading

Mentioned in

Formats

Tip

Use different formats to  your . For structure content
example, use Heading 1 and Heading 2 to list two 
text elements hierarchically.
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General information
General information can be provided to DRM via an 
interface to . They can a requesting system (e.g. LIMS, LIS)
be inserted into the delivered content automatically. 

are case-specific data, e.g. patient age, sex or previous 
diagnoses
can be included in  or   by content elements templates
placeholders
can be adressed in the  effecting the delivery of rule engine
diverse content for certain conditions
can be required, protected, computed, linked to parameter(s) 
and/or multiple for input elements (for details see General 

)information

Mentioned in

General information
Viewing content
Default setting of general information
Adding new general information
Editing general information
Removing general information
Setting the rule for general information
FAQ DRM

Tip

By generating content boxes that follow a general 
information-dependent rule, it is possible to 
prepare reports with case- or patient-specific data 
automatically.

https://confluence.biologis.com/display/HBGIMS/Template
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Inactive parameter
If a  is not needed anymore, it can be inactivated. parameter
An inactive parameter is not shown on the , parameter tree
in the Edit or View tabs.

 

only possible if the   is not used in any  or parameter rule
 of the placeholder content

is displayed gray on overview of parameters
can be reactivated

Mentioned in

Inactivating a parameter
Reactivating a parameter
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Machine name
A machine name allows the system to identify entities. It is 
similar to the label or title of an entity which is more 
readable for users, but may not be unique and contain 
special characters.

how the  is identified in the receiving system (e.g. the section
LIMS or GIMS RLE)
contains only lowercase letters, numbers, and underscores
is unique

Mentioned in

Generating a processor chain
Adding a new section
Section
Sections overview

https://confluence.biologis.com/display/HBGIMS/Generating+a+processor+chain
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Measurement
Measurements can be provided to DRM via an interface to a 

. They can be inserted requesting system (e.g. LIMS, LIS)
into the delivered content automatically. 

are case-specific results, e.g. blood values, ferritin levels
can be included in  or   by content elements templates
placeholders
are inserted in a table
can be adressed in the  effecting the delivery of rule engine
diverse content for certain measurement
can be required, computed, linked to parameter(s) and/or 
multiple for input elements (for details see )Measurements

Mentioned in

Measurements
Viewing content
Default setting of measurements
Adding new measurements
Editing measurements
Removing measurements

Tip

By generating content boxes that follow a 
measurement-dependent rule, it is possible to 
prepare reports with case- or patient-specific data 
automatically.

https://confluence.biologis.com/display/HBGIMS/Template
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Media element
A media element is a specific  which content element
contains images with captions.

the  of images are .jpg or .png, whereas the caption is format
restricted to html
can be embedded in different sizes and positioning in the 
content
following content elements can wrap it
can be tagged
can have notes
reusable by integrating the same image
is located in  within a content content box
caption can contain placeholders
translatable
editing history can be traced at Revisions tab
translations can be marked as outdated

Mentioned in   

Viewing content elements
Adding content elements
Editing a content element
Using similar content elements
Adding notes to content elements
Removing content elements from content
Moving a content element
Translating content elements
Managing content element revisions

Tip

Media elements can be managed in the image 
database, reused and edited in different contexts.
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Metadata
Metadata are data that deliver additional information about a 
parameter. 

 

inserted into the content via placeholders
is set visible/hidden for a  of parametersclass
more  can be metadata fields added
has a  where it is validcontext

Mentioned in

Replacing a dummy parameter
Editing metadata of a parameter
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Metadata context
Metadata context defines where the  of a metadata

 is valid.parameter
 

two contexts are available: global and local
local metadata is saved per content
global metadata is independent of the content
local metadata has a higher priority than global metadata
initially, a  has only global metadataparameter
dummy parameters have only local metadata

Mentioned in

Replacing a dummy parameter
Editing metadata of a parameter
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Metadata field
A metadata field stores  of the .metadata parameter

has a label
can be translatable
can contain multiple values
generated globally, i.e. across all contents
by default, it is set hidden

Mentioned in

Adding a new metadata field
Adding and editing parameters
Adding and editing a class
Editing a placeholder

Tip

In order to be flexible with using , it is placeholders
recommended to store the   in several metadata
small fields instead of one big one.



Manual GIMS 1.12

270

Note
A note contains information about the .content element

notes are shown on all translations of content elements
are deposited with date and author
cannot be deleted

Mentioned in

Viewing notes of content elements
Adding notes to content elements

Tip

Use notes on content elements to document why a 
specific change was made.
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Order action
The order action describes the current step in 
the processing of a .report order

 

possible values
Created: a new   is createdreport order
Reordered: an existing   is reorderedreport order
Processed: the delivered  and  of the order are uuid parameters
assigned to existing content
Waiting for RLE: the report order is ready for processing in the 
report layout engine
Processing in RLE: the report order is processed in the report 
layout engine
Finished / Response delivered: the processed   is report order
finished / delivered
RLE error: there was an error while creating the report in the 
report layout engine
has a processing status

Mentioned in

Viewing a report order
Report orders overview

https://confluence.biologis.com/display/HBGIMS/Report+Layout+Engine
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Outdated
A marker to indicate whether the corresponding content 

needs to be updated.element 

 

Single translated content elements are automatically marked 
as outdated. The label can be resolved, if no changes are 
necessary. Otherwise content elements in translated contents 
are marked as outdated, too. The labelling is only cancelled, 
when the element is .approved
Mark other translations as outdated in case the content in other 
languages needs to be edited.
Mark a published content element as outdated in case of literal 
mistakes.
Mark a published content element and its translations as 
outdated in case of content-related mistakes.

The outdated status corresponds to the  of workflow state
the content element:

A content element that is published loses the outdated 
marking. Remove the mark if the mistake is corrected 
by .publishing a content element translation
An already published content element falls back into 
the content element workflow state 'in progress' when 

.it is marked as outdated

Please note: The workflow of content elements is 
defined independently of the workflow of contents. 
Therefore, publishing contents do not affect the 
workflow state of content elements included in the 
content and their marking as outdated. The workflow 
can be modified by the , see Workflow Editor editing a 

.workflow

Mentioned in

Viewing content elements
Editing a content element
Translating content elements
Publishing content

 

 

Tip

Mark content elements that need to be updated.
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Page fragment
Page fragment is a  predefinedcontent type  for managing 
sections used in more than one content. 

content elements can be deposited into a section which is to be 
integrated to a target content
sections with dynamic content e.g. sidebar, header or footer 
can be linked   by into other contents  content integration
it is recommended to set up corresponding sections in the final 
content for each used page fragment, this facilitates assigning 
different styles to a section or the  of sections in the positioning
delivered content

Mentioned in

Adding new content

Example:
The information for the sidebar of clinical reports can be set 
up as  in a page fragment andcontent elements  added by 
content integration in the provided sections of different 
clinical reports. Modifications of the page fragment section 
are directly available in all reports which use the page 
fragement.

Tip

The usage of placeholders in the section of page 
fragment creates dynamic elements, which can be 
used in more than one content. Depending on the 
data defined for the placeholders in the final 
content, a content specific report can be generated.
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Parameter
A parameter is a patient-specific data that is transmitted to 
DRM (e.g. from a LIMS). It can be any patient-specific data 
(e.g. genetic testing results) other than general information 
(e.g. patient name) or measurement (e.g. blood ferritin 
level). A parameter associated with a determines the rule 

 output.content

identified by its external ID
can be used on different content
sorted with  into a classes parameter tree
presented by a file in the parameter tree
can have metadata
used for evaluating the rules
used for replacing placeholders
only generated for a report order
if not yet available, a  can be used dummy parameter
can be set inactive

Mentioned in

Publishing content
Editing metadata of a parameter
Adding and editing a class
Viewing content history
Viewing content
Generating a parameter tree
Editing a placeholder
Replacing a dummy parameter
Setting the rule of a content box
Translating contents
Viewing content workflow states
Parameter overview
Viewing a report order
Overview of report orders

Tip

Foremost, parameters are test results from the 
laboratory. They can be complemented by 
additional case-specific data, e.g. patient age, sex 
or previous diagnoses.



Manual GIMS 1.12

275

Dummy parameter
A dummy parameter is used in a content when the needed 

 is not yet available.parameter

created by the user
displayed in the  like a real parameterparameter tree
used in , , etc. like a real parameterrules placeholders
can carry local metadata
can be replaced with a real parameter

Mentioned in

Replacing a dummy parameter
Adding and editing parameters
Generating a parameter tree
Editing metadata of a parameter

Tip

Use dummy parameters to write content in 
advance.
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Real parameter
A real  is an information, usually a result, which is parameter
transmitted to the DRM as a part of a report order, e.g. from 
a LIMS.

not created by the user
displayed in the parameter tree
used in  and rules placeholders
can carry local and global metadata
can be included in the parameter tree of other contents

Mentioned in

Replacing a dummy parameter
Adding and editing parameters
Generating a parameter tree
Editing metadata of a parameter

Tip

Real parameters, which already exist in a given 
DRM instance, can be reused directly in other 
contents.
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Parameter tree
A parameter tree represents the logical hierachy of the 

 of the .parameters content

determines how efficiently the   can be writtencontent
is the same for all translations of the content
contains  and parameters classes
the root is the preset class All parameters
new   are initially placed outside of the treeparameters
each   must be at the end of a branchparameter
below a , there can be no other   or .parameter parameter class
used for setting  and rules placeholders

Mentioned in

Generating a parameter tree
Editing a placeholder
Setting the rule of a content box

Tip

It is recommended to sort  of the same parameters
type (for example genotype, phenotype) into a 
shared . Within these classes, subclasses for class

 which should lead to similar   parameters content
output can be added.
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1.  

2.  

3.  

1.  
2.  
3.  

Placeholder
Placeholders can be used within a  or content element

 to template create fields where case specific information 
can be brought directly from external systems, e. g.  a LIMS.

Placeholders can be filled with backup information of:

: Parameters backup information for parameters can be 
provided as .metadata

: all  InformationGeneral information assigned to the general 
Information in the settings can be integrated as placeholders in 

.the content element
: Measurements all information assigned to the measurements 

in the settings can be integrated as placeholders in the content 
element.

Three types of placeholders with different functions are 
available:

Placeholders in general
Iterative placeholders
Flexible placeholders

Please note:

Only letters (without umlauts), numbers and underscores are 
allowed for naming the placeholders. Special characters cannot 
be used.
Styling of the entire placeholder is possible, but single areas 
can not be styled differently.
Default values of general information or measurements are 
used for placeholders if no other value is transmitted from the 
requesting system (e.g. LIMS, LIS).
Placeholders within integrated content will be filled with the 
information of their content ( ).content integration
In case of enumerations in one placeholder, delimiters between 
the transferred values can be freely configured.

Mentioned in

Viewing placeholders
Adding a placeholder
Editing a placeholder
Removing a placeholder

Tip

Use placeholders to increase the reusability of 
content elements.

https://confluence.biologis.com/display/HBGIMS/Template
https://confluence.biologis.com/pages/viewpage.action?pageId=35750958
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Flexible placeholder
A flexible placeholder is a string in the  or  content template
that will be replaced during the  by a value report generation
defined by the user (such as  or general information

) manually or delivered automatically from measurements
a requesting system (e.g. LIMS, LIS).

starts with [# and ends with #]

For :generating report previews

can be inserted in the  and in template content elements
is replaced for each newly generated report preview
values are defined manually by the user during the report 
generation
is deleted in the generated document if no value has been 
defined

For automated :report orders

can be inserted in content elements
is still existent within the delivered report
can be accessed and replaced by a requesting system (e.g. 
LIMS, LIS)

Mentioned in

Template
Generating a report preview
Editing a placeholder
Adding a flexible placeholder

 

 

Tip

Use the placeholders for values not saved within 
the GIMS.

https://confluence.biologis.com/display/HBGIMS/Template
https://confluence.biologis.com/display/HBGIMS/Template
https://confluence.biologis.com/display/HBGIMS/Template
https://confluence.biologis.com/display/HBGIMS/Adding+a+flexible+placeholder
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Iterative placeholder
An iterative placeholder is an extension of placeholders to 
generate an automated (tabular) listing.

 

includes {{ before and }} after an existing placeholder
only within a table or list (bulleted or numbered) in content 

 availableelements
iterated over all selected parameters, general information or 
measurements to collect and list the selected metadata/settings
for tables including both iterative placeholders and static 
content, the static content is replicated for each row

the following placeholders can be converted to iterative ones:
parameter placeholders
general information placeholders
measurement placeholders

Mentioned in

Adding an iterative placeholder
Editing a placeholder

 

Tip

With one placeholder, it is possible to list multiple 
metadata fields of parameters or settings of 
general informations, measurements.

https://confluence.biologis.com/display/HBGIMS/Adding+an+iterative+placeholder
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General information placeholder
A general information placeholder is a string in the  content
that will be automatically replaced by the assigned  of value
a given .general information

consists of three parts
1. : with name or ID if no name is setGeneral information

: a list of all general information 2.  information settingGeneral
settings e.g. value, name, description
3. String: how the placeholder is written in the text, has to start 
with [[ and end with ]]
placeholders can be marked with  for text editor features
defining individual layout in the output

Mentioned in

Editing a placeholder
Adding a general information placeholder

Tip

By using placeholders, it is possible to reduce the 
number of .content elements
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Measurement placeholder
A measurement placeholder is a string in the  that content
will be automatically replaced by the value of the assigned 
measurement setting.

consists of three parts
1. Measurement: with name or ID if no name is set

: a list of all measurements settings 2. Measurement setting
3. String: how the placeholder is written in the text, has to start 
with [[ and end with ]]
placeholders can be marked with  for text editor features
defining individual layout in the output

Mentioned in

Editing a placeholder
Adding a measurement placeholder

Tip

By using placeholders, it is possible to reduce the 
number of .content elements
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Parameter placeholder
A parameter placeholder is a string in the  that will content
be automatically replaced by the value of the assigned 

 of the respective .metadata field parameters

consists of three parts
1. Parameter : per default, is selected  but class  All parameters ,
if it is necessary to exclude  in the replacement, the parameters

 can be opened and a more specific class can parameter tree
be set

: per default,  is selected, but the value 2. Metadata field Name
of any  can be selectedmetadata field
3. String: how the placeholder is written in the text, has to start 
with [[ and end with ]]
placeholders can be marked with  for text editor features
defining individual layout in the output

Mentioned in

Editing a placeholder
Adding a parameter placeholder

Tip

By using placeholders, it is possible to reduce the 
number of .content elements
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Rule-based placeholder
A rule-based placeholder is an extension of placeholders to 
generate a variable, rule dependent paragraph in a content 
element independently of metadata.

 

the string has to start with [[ and end with ]]
available within text, a table or list (bulleted or numbered) in 
content elements
can be linked to other  by content boxes exclusion sets
the placeholder is replaced with the content of the linked 
includable content boxes if their rules match. Only the content 
of the first content box with fulfilled rules is displayed.
headings and tables cannot be used in includable boxes to 
prevent invalid nesting
media and barcode elements are not supported in includable 
boxes

the following placeholders can be incorporated into rule-based 
placeholders:

parameter placeholders
general information placeholders
measurement placeholders

Mentioned in

Editing a placeholder
Adding an rule-based placeholder

 

Tip

Rule-based placeholders can be used to generate 
lists or tables with rule dependent content.
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Processing status
The processing status describes the current state in 
the processing of a report order.

is depicted by an icon
can have different meanings depending on the corresponding 
order action

Created:

 the order is created and pending for processing

Reordered:

 the reorder is pending for processing

Processed:

 the order could not be processed due to an error

  the order is processed and pending for delivery

Response delivered:

 an error occurred during the response delivery

the response is delivered

Mentioned in

Viewing a report order
Report orders overview

Tip

Look at the log messages for further details of the 
current order status.
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Processor chain
When a  has variables such as , content parameters general 

 or , a processor chain is used to information measurements
provide their values.

for each , a custom processor chain can be configured content
by the administrator
can make highly specific information available like the 
chromosome aberration extracted from the karyotype
general information or measurements that were generated by 
the processor chain from other variables are called computed

Mentioned in

Setting the used processor chain
Viewing content

Tip

Please contact your support to set up the 
processor chains depending on your set up.
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Reference
A reference links to registered literature.  

is allocated to a  and valid for all  content box content elements
in the respective content box
can be defined in the right side bar within the Content box 

on the tabattributes  Edit 
the last   of the  is automatically generated and section content
contains all the references of all shown content boxes in their 
order of usage, assigned by number
on the , the assigned number of the references are content view
shown below their content box

Mentioned in

Setting references to a content box
Editing content
Viewing content
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Report order
A report order represents an external request of  for content
a set of .parameters

holds metadata of the request such as order ID, orderer, 
translation, patient ID
is in an order action
has an processing status

Mentioned in

Viewing a report order
Report orders overview
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Role
A role defines a set of tasks the  is permitted to perform.user

The following roles and their  can be assigned to permissions
users:

Role Permissions

Content 
Approver

approve content

Content Editor edit and translate  and content content 
elements

Content 
Publisher

publish   content

Content 
Reviewer

review   content

Content 
Settings Editor

edit   settingscontent

Content Viewer view   with  and content revisions
, view workflow states content elements

Custom Style 
Editor

add and edit custom styles

Order 
Processor 
Chain Editor

add and edit processor chains

Order 
Processor 
Chain Viewer

view processor chains

Parameter 
Editor

administer  and their parameters
metadata

Report Order 
Viewer

view orders

Section 
configurator

configure sections

Template 
Viewer

view templates

Template Editor add and edit templates

Template 
Approver

approve templates

Template 
Publisher

publish templates

Template review templates

Mentioned in

Viewing user list
Editing user profile
Adding an user account

Tip

Use roles to control what each  is allowed to user
do.

https://confluence.biologis.com/display/HBGIMS/Template
https://confluence.biologis.com/display/HBGIMS/Template
https://confluence.biologis.com/display/HBGIMS/Template
https://confluence.biologis.com/display/HBGIMS/Template
https://confluence.biologis.com/display/HBGIMS/Template
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Reviewer

Content 
Element 
Approver

approve content element

Content 
Element 
Publisher

publish content element

Content 
Element 
Reviewer

review content element

User 
Administrator

administer  and their rolesusers

Workflow Editor view, add and edit  and workflows
workflow graphs
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Rule
A rule is evaluated by the Genetic Report Engine and 
defines under which circumstances which text should be 
displayed on the .content

is defined for each  and valid for all content box content 
 in the content boxelements

is shown on the , when hovering over a content view content box
can be defined in the right side bar within the Content box 

on the tabattributes  Edit 
consists of different statements that are logically connected by 
OR or AND
a statement can be Always true
can include ,  and/or parameters general information
measurements

Mentioned in

Viewing content
Setting the rule of a content box
Translating contents
Editing content

a statement can depend on the :parameters

statement TRUE if

Results are in the  selectionparameter tree at least one parameter is given which is one of the selected parameters or in one of the 
selected classes

...  y zwith metadata matching exactly at least one of the given parameters of the selected parameters or in one of the selected 
classes have the value z for the metadata y

are not inResults  the  selectionparameter tree no parameter is given which is one of the selected parameters or in one of the selected 
classes

...  y zwith metadata matching exactly no parameter of the selected parameters or in one of the selected classes have the value 
z for the metadata y

match at leastResults  x  the Parameter(s) in
 selectionparameter tree

at least x parameters are given which are of the selected parameters or in the selected 
classes

...  y zwith metadata matching exactly at least x parameters of the selected parameters or in the selected classes have the 
value z for the metadata y

match at leastResults  x  the Class(es) of
 selectionparameter tree

the given parameters belong to at least x of the selected classes

match up toResults  x  the Parameter(s) in
 selectionparameter tree

up to x parameters are given which are of the selected parameters or in the selected 
classes

... with metadata y matching exactly z up to x parameters of the selected parameters or in the selected classes have the value z 
for the metadata y

match up toResults  x  the Class(es) of
 selectionparameter tree

the given parameters belong to up to x of the selected classes

match exactlyResults  x  the Parameter(s) in
 selectionparameter tree

exactly x parameters are given which are of the selected parameters or in the selected 
classes

... with metadata y matching exactly z exactly x of the given parameters have the value z for the metadata y

match exactlyResults  x  the Class(es) of
 selectionparameter tree

the given parameters belong to exactly x of the selected classes

match all  the Results Parameter(s) in
 selectionparameter tree

all parameters of the selected parameters or in the selected classes are given

... with metadata y matching exactly z those parameters of the selected parameters or in the selected classes are given which 
have the value z for the metadata y

match allResults Class(es) of the parameter 
 selectiontree

the given parameters belong to all of the selected classes

a statement can depend on :measurements
for comparing the value of a measurement m with a reference value
a reference value can be

a  (defined in the input field 'custom value')Custom value
the  valueAlarm
a  (either ,  or )Reference value Discrete Maximum Minimum
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one of the five Preceding values
the  input field is just required if  is selected'custom value' Custom value

statement TRUE if

Measurement m  20> Custom value the value of measurement m is greater than the user defined value '20'

Measurement m = Discrete the value of measurement m equals the discrete reference value

Measurement m  20 < Minimum x % the value of measurement m is smaller than '20' % of the minimum reference value

a statement can depend on :general information
for comparing the value of a general information g with a user defined value

statement TRUE if

General information g is true a value is set for general information g

General information g male equals the value of general information g equals 'male'

General information g al contains the value of general information g contains 'al'

General information g ma starts with the value of general information g starts with 'ma'

General information g le ends with the value of general information g ends with 'le'

a statement can depend on  and parameters general information

a statement can depend on  and parameters measurements

if the content should never be shown, it can be set inactive
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Section
Content is . managed per sections for a better overview
Sections of the same document can have different attributes.

has a label
has a  (only alphabetic characters) by which it is machine name
identified in the receiving system (e.g. LIMS, GIMS RLE)
shown as  or consecutively whentab  viewing content
shown as tab when editing content
can get individual layout stylings
can be  integrated into another content
can be marked as relevant, so that it will be included in checks 
for completeness (e.g. a given parameter might be relevant for 
one section and obsolete for another section at the same time)
can be edited
new sections can be added

the last section is automatically generated and contains the 
references
number and names of sections depend on the content type
it is possible to switch between sections without saving 
previous changes
removal of a section is possible only when none of its 
translations contain any content

Mentioned in

Viewing content
Editing content
Moving a content box
Adding a content box to content
Integrating content
Template
Set default set of sections for new content
Sections overview
Editing a section
Adding a section to content
Adding a new section
Configuring sections

Tip

The receiving system can decide which s to section
use and in which order. It can also add other 
content between the received s.section

https://confluence.biologis.com/display/HBGIMS/Template
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Tag
Tags group different  with content elements all their 
translations to enable filtering.

free tagging of content elements 
already existing tags in dropdown menu offered
multiple tagging by lists possible

linked to a specific ID
filtering by single tags or combined search with further tags and
/or other filter options

Mentioned in:

Working with tags
Text elements overview
Media elements overview

Tip

Use tags on content elements to manage content 
with similar topics.
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Test drive
A clone of the productive DRM environment for testing 
purposes.

 

accessible via https://[YOUR_GIMS_URL]/testdrive
isolated from the the productive instance
upon request, all changes to the content are erased and 
replaced by the latest productive data

Mentioned in

Using the test drive environment

 

 

Tip

The test drive environment of DRM is very useful 
to try new features or to test the communication 
between a requesting system (e.g. LIMS, LIS) and 
GIMS.
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Text element
A text element is a specific  which contains content element
the actual text.

the  is restricted htmlformat
can contain placeholders
can have notes
reusable: can be used several times within the same  content
as well as in other contents
is located on  within a content content box
translatable
editing history can be traced at Revisions tab
translations can be marked as outdated

Mentioned in

Using similar content elements
Adding content elements
Viewing a text element
Translating content elements

Tip

In order to increase the reusability of text elements, 
it is recommended that the text contains only one 
statement.
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Toolbar
The toolbar contains the entry points for all major tasks.  

can be hidden
can be moved

Mentioned in

Using the toolbar
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Translation element
A translation element is a specific  which content element
contains the actual text.

Translation elements differ from other content elements. 
Since their content is imported there are some exceptions 
for translation elements:

they are only visible in the   listTranslation elements overview
they can not be added manually to the content but are imported 
upon request 
translations are automatically generated if is translated content 
into a new language
it is not possible to edit or reuse translation elements or to add 
notes to them in the content

the  is restricted htmlformat
editing history can be traced at Revisions tab
translations can be marked as outdated
translation elements that are imported and not meant to be 
edited in GIMS DRM, can be locked

Mentioned in

Translation elements overview
Viewing a translation element
Editing a translation element
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User
A user is a person or a system that has access to GIMS.

needs name and password for logging in
has roles
has a status: active (is allowed to log in) or blocked (cannot log 
in)
changes to content or workflows made by the user are 
traceable

Mentioned in

Using the toolbar
Content overview
Viewing user list
Publishing content
Viewing content history
Viewing content workflow states
Editing a workflow

Tip

Do not share a login credentials with other users in 
order to have a reliable version history.
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UUID
The  is the unique universal identifier of the .uuid content  

is automatically given to new content
same for all content translations
needed by the requesting system (e.g. LIMS, LIS)

Mentioned in

Content overview
Report orders overview
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Warning
A warning informs the  that a  is incomplete or user content
contradictory and prevents changing the .workflow state

 

 

troubleshooting lists all possible warnings and how to react Mentioned in

Viewing content
Viewing content workflow states
Publishing content
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Workflow
The workflow defines release processes, consisting of 
several states, which guarantee that content components 
are reviewed several times by differently authorized users 
before they are published and made availlable for report 
generation.

It describes how and when components pass the different 
states of the  before being published for workflow graph
delivery.

 

 

can be used for different components (e.g. ,  or content template
)content element

consists of a  with configurationworkflow graph
each content can have its own workflow
a default workflow is provided on installation
defines which   is considered publishedworkflow state
defines which   is used as defaultworkflow state
defines the  to which  is reset after being workflow state content
edited, depending on the change class
defines which  is allowed to do which role workflow transition

Mentioned in

Viewing content workflow states
Overview of workflows
Publishing content
Publishing content element
Publishing a template
Setting the used workflow to content

https://confluence.biologis.com/display/HBGIMS/Template
https://confluence.biologis.com/display/HBGIMS/Publishing+a+template
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Workflow graph
A workflow graph describes the different states  can content
be in.

 

 

consists of  and workflow states workflow transitions
a default workflow graph is provided on installation
can be used by different workflows
has to contain at least the four preset workflow states

Mentioned in

Adding a new workflow
Editing a workflow graph
Editing a workflow
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Workflow state
A workflow state describes where  is in process of content
publishing.

 

 

content can be in different workflow states depending on the 
 selectionparameter

the  defines which   is considered workflow workflow state
published
the  defines which   is used as defaultworkflow workflow state
the  defines into which    falls workflow workflow state content
after being edited, depending on the change class
the most recently published version is delivered, in case 
content is into a non-published state
default  are displayed orangeworkflow states
custom  are displayed blueworkflow states

Mentioned in

Moving a workflow state
Renaming a workflow state
Adding a new workflow transition
Moving a workflow transition
Viewing content workflow states
Adding a new workflow state
Removing a workflow state
Editing a workflow
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Workflow transition
A workflow transition defines which  follows workflow state
another .workflow state

 

 

the  defines which  is allowed to do which workflow workflow role
transition
warnings prevent the transition

Mentioned in

Adding a new workflow transition
Editing a workflow
Removing a workflow transition
Moving a workflow transition
Renaming a workflow transition
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Troubleshooting DRM
Problem Message Possible reason how to react

Warning on content 
.view

Incomplete content detected: No influence by 
 "parameter".parameter

The   does not parameter
influence the output of the 

 and is therefore not content
needed.

Inactivating the parameter.

The  should parameter
influence the output of the 

 which has to be edited.content

Editing the content, for example 
changing  to consider the rules
parameter, or adding new text.

Contradictory content detected: "  1" content box
and "  2" of the same  content box exclusion set
were matched.

One of the content boxes 
should not be displayed, as 
their text is contradictory.

Editing the rules of at least one 
of the content boxes.

The content boxes should both 
be displayed, as their content 
is not contradictory, and must 
not be in the same exclusion 

.set

Editing the exclusion set of at 
least one of the content boxes.

Incorrect headings: heading is the first heading 
on the   and has to be "Heading 1" or section
"Heading 2".

The level of the first headings 
is too high.

Editing the content, so that the 
headings do not prevent the 
delivery of valid HTML.

Incorrect headings:  . heading Just one "Heading 
1" allowed per .section

More than one heading 1 per 
.section

Incorrect headings:  is a "Heading x" heading 1
and must not follow the "Heading y" .heading 2

The level of headings has to 
either remain, decrease or 
increase by 1: x <= (y+1)

Cannot select a new 
.workflow state

  There are .warnings Editing the content.

The  does not have the user
needed .role

Editing the user's profile to have 
the missing .role

Editing the used workflow to 
allow the  for one of transition
the  user's role.

Cannot inactivate a 
parameter.

  The  is used in a  parameter rule
or a  of the .placeholder content

Checking all  or a rules
 of the   and, placeholders content

if possible, removing the 
.parameter

Cannot set a 
.reference

  The desired reference is not 
yet available.

Contacting the administrator, 
providing the DOI of the desired 
reference.

Cannot save a form.   There are validation errors. Editing the form values, so that 
the errors do not apply anymore 
and disappear.

Processing status of 
 is "the report order

order could not be 
processed due to an 
error"

Order " " in revision " ": No id revision  report
 found for the given  " " with mapping report report

language code " ".language

There exists no  with content
the requested .UUID

Checking the available   UUIDs
on the , overview of contents
and reconfiguring the 
requesting system.

Order   in revision : None  id revision published
 revision found for the given   "report report report

" in language " ".language

The   is not ready to be content
delivered.

Editing and  the  publishing
content.

Order   in revision : No suitable report id revision
revisions found for the given   " " in report report
language " ". Possible reason might be language
a change of the  on .parameter tree date

Order   in revision : A published   id revision report Depends on the given error  
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revision with errors found for the given   "report
" in language " " in its revision "report language

". Error messages: revision messages

messages. For example, not all 
 could be replaced placeholders

due to missing .metadata

Order   in revision : Incomplete or id revision
wrong  provided for the given   "results report

".report

Depends on the given error 
messages. For example, not all 
needed general information or 
measurements are provided.

Contacting the administrator 
responsible for linking the CMS 
and other systems.

An exception has been thrown while saving a 
new revision with response of   in report order
revision   at time  in . revision time function
Exception code: . Exception message: code
message

An internal error. Contacting the administrator.

Processing status of 
 is "an report order

error occurred 
during the response 
delivery"

An exception occurred while sending a 
response for an  in . report order method
Exception code: . Exception message: code

.message

Order  : during processing an exception has id
been thrown. Exception code: . Exception code
message: .message

Order   in revision : errors during the id revision
 generation have been sent back for the report
 " " in language " ".report report language

One of the above errors. Seeing the other messages for 
more details.

Processing status of 
 is "RLE report order

error"

An internal error. Contacting the administrator.

Processing status of 
 is "the report order

response is 
delivered"

 Order  in revision : has been id revision
   successfully processed for the given report "

" in language " ".report language

The   is published report
delivered successfully.

-

 

  The newest version of the report was 
processed.

The latest   is published report
delivered, which is also the 
latest version of the .content

-

      An edited but unpublished version of the report
exists.

 The latest   is published report
delivered but a newer version 
exists.

Checking if the changes to the 
content are important for the 
report. If this is the case, 
publish the content and reorder 
the report.

Cannot see tags Tags are not shown on the overview of  or text
.media elements

Filter setting include no content 
elements with tags.

Extend the filter selection to see 
the tag list for further 
specification by tag search.
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